aboutsummaryrefslogtreecommitdiffstats
path: root/FAQ
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /FAQ
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'FAQ')
-rw-r--r--FAQ38
1 files changed, 33 insertions, 5 deletions
diff --git a/FAQ b/FAQ
index 49f0c98..16fbff7 100644
--- a/FAQ
+++ b/FAQ
@@ -1,4 +1,4 @@
-FAQ (Frequently Asked Questions and answers) for SLIB Scheme Library (slib3a4).
+FAQ (Frequently Asked Questions and answers) for SLIB Scheme Library (slib3a5).
Written by Aubrey Jaffer (http://swiss.csail.mit.edu/~jaffer).
INTRODUCTION AND GENERAL INFORMATION
@@ -14,9 +14,10 @@ Scheme is a programming language in the Lisp family.
[] Which implementations has SLIB been ported to?
-SLIB supports Bigloo, Chez, ELK, GAMBIT, Guile, MacScheme, MITScheme,
-PLT Scheme (DrScheme and MzScheme), Pocket Scheme, RScheme, scheme->C,
-Scheme48, SCM, SCM Mac, scsh, Stk, T3.1, umb-scheme, and VSCM.
+SLIB supports Bigloo, Chez, ELK 3.0, GAMBIT 3.0, Guile, JScheme,
+MacScheme, MITScheme, PLT Scheme (DrScheme and MzScheme), Pocket
+Scheme, RScheme, scheme->C, Scheme48, SCM, SCM Mac, scsh, Stk, T3.1,
+umb-scheme, and VSCM.
[] How can I obtain SLIB?
@@ -46,7 +47,7 @@ Several times a year.
[] What is the latest version?
-The version as of this writing is slib3a4. The latest documentation
+The version as of this writing is slib3a5. The latest documentation
is available online at:
http://swiss.csail.mit.edu/~jaffer/SLIB.html
@@ -206,3 +207,30 @@ As explained in the Repl entry in slib.info (or slib.texi):
(require 'macro)
(require 'repl)
(repl:top-level macro:eval)
+
+ SRFI
+
+[] What is SRFI?
+
+"Scheme Requests for Implementation" is a process and informal
+standard for defining extensions to Scheme.
+
+[] Which SRFIs does SLIB support?
+
+These can be REQUIREd by the listed (srfi) feature name:
+
+srfi-0: Feature-based conditional expansion construct
+srfi-1: List Library
+srfi-2: AND-LET*: an AND with local bindings, a guarded LET* special form
+srfi-8: receive: Binding to multiple values
+srfi-9: Defining Record Types
+srfi-11: Syntax for receiving multiple values
+srfi-23: Error reporting mechanism
+srfi-28: Basic Format Strings
+srfi-47: Array
+srfi-59: Vicinity
+srfi-60: Integers as Bits
+srfi-61: A more general cond clause
+srfi-63: Homogeneous and Heterogeneous Arrays
+srfi-94: Type-Restricted Numerical Functions
+srfi-95: Sorting and Merging