aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control6
-rw-r--r--debian/patches/kfreebsd_support.patch46
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules3
5 files changed, 65 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 60fd780..f7e879a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+scm (5e5-3.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ ACKed by maintainer.
+ * Update debian/control.
+ - Add support sh4, kfreebsd-amd64 and kfreebsd-i386.
+ (Closes: #558213, #559017)
+ - Replacing libreadline5-dev build dependency with libreadline-dev.
+ (Closes: #553847)
+
+ -- Nobuhiro Iwamatsu <iwamatsu@debian.org> Mon, 01 Mar 2010 14:58:29 +0900
+
scm (5e5-3) unstable; urgency=low
* build.scm (build-continue-ia64): New function, to encapsulate the method
diff --git a/debian/control b/debian/control
index 78db91d..5694a16 100644
--- a/debian/control
+++ b/debian/control
@@ -3,10 +3,10 @@ Section: interpreters
Priority: optional
Maintainer: Thomas Bushnell, BSG <tb@debian.org>
Standards-Version: 3.7.3
-Build-Depends: slib (>> 3b1), libncurses5-dev, libreadline5-dev, texi2html, texinfo, libx11-dev, debhelper (>= 5)
+Build-Depends: slib (>> 3b1), libncurses5-dev, libreadline-dev, texi2html, texinfo, libx11-dev, debhelper (>= 5), quilt
Package: scm
-Architecture: alpha amd64 arm hppa i386 hurd-i386 m68k mips mipsel powerpc ppc64 sparc ia64 armel armeb
+Architecture: alpha amd64 arm hppa i386 hurd-i386 m68k mips mipsel powerpc ppc64 sparc ia64 armel armeb sh4 kfreebsd-amd64 kfreebsd-i386
Section: interpreters
Priority: optional
Depends: slib (>> 3b1), ${shlibs:Depends}
@@ -15,7 +15,7 @@ Description: A Scheme language interpreter
the IEEE P1178 specification.
Package: libscm-dev
-Architecture: alpha amd64 arm hppa i386 hurd-i386 m68k mips mipsel powerpc ppc64 sparc ia64 armel armeb
+Architecture: alpha amd64 arm hppa i386 hurd-i386 m68k mips mipsel powerpc ppc64 sparc ia64 armel armeb sh4 kfreebsd-amd64 kfreebsd-i386
Section: libdevel
Priority: optional
Depends: scm (= ${binary:Version}), slib (>> 3b1), ${shlibs:Depends}
diff --git a/debian/patches/kfreebsd_support.patch b/debian/patches/kfreebsd_support.patch
new file mode 100644
index 0000000..07166a0
--- /dev/null
+++ b/debian/patches/kfreebsd_support.patch
@@ -0,0 +1,46 @@
+--- scm-5e5.orig/time.c
++++ scm-5e5/time.c
+@@ -73,7 +73,7 @@
+ /* Define this if your system lacks times(). */
+ /* #define LACK_TIMES */
+
+-#ifdef linux
++#if defined(linux) || defined(__GLIBC__)
+ # include <sys/types.h>
+ # include <sys/time.h>
+ # include <sys/timeb.h>
+only in patch2:
+unchanged:
+--- scm-5e5.orig/scmfig.h
++++ scm-5e5/scmfig.h
+@@ -310,7 +310,7 @@
+ # define STDC_HEADERS
+ #endif
+
+-#ifdef linux
++#if defined(linux) || defined(__GLIBC__)
+ # define HAVE_SELECT
+ # define HAVE_SYS_TIME_H
+ # define STDC_HEADERS
+@@ -755,7 +755,7 @@
+ # include <unistd.h>
+ #endif
+
+-#ifdef linux
++#if defined(linux) || defined(__GLIBC__)
+ # include <unistd.h>
+ #endif
+
+only in patch2:
+unchanged:
+--- scm-5e5.orig/findexec.c
++++ scm-5e5/findexec.c
+@@ -51,7 +51,7 @@
+ # include <sys/file.h>
+ # include <sys/param.h>
+ # endif
+-# ifdef linux
++# if defined(linux) || defined(__GLIBC__)
+ # include <string.h>
+ # include <stdlib.h>
+ # include <sys/stat.h>
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..90849f4
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+kfreebsd_support.patch
diff --git a/debian/rules b/debian/rules
index e8f5033..792147e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -67,6 +67,7 @@ build: build-stamp
build-stamp:
chmod +x build
dh_testdir
+ QUILT_PATCHES=debian/patches quilt push -a || test $$? = 2
cp debian/require.scm.debian require.scm
ifeq ($(DEB_BUILD_ARCH), m68k)
${MAKE} scmlit CFLAGS="-g -Wall" ARCH=$(DEB_BUILD_ARCH)
@@ -105,8 +106,10 @@ clean:
make distclean
-rm -f srcdir.mk
-rm -f debian/bld
+ -rm -rf libscm.a
-rm -rf *~ debian/*~ debian/tmp* debian/files debian/substvars
+ QUILT_PATCHES=debian/patches quilt pop -a -R || test $$? = 2
dh_clean
binary-indep: build install