aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile343
1 files changed, 213 insertions, 130 deletions
diff --git a/Makefile b/Makefile
index 46c0ed1..f4465f5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,18 +1,18 @@
-# Copyright (C) 1990, 1991, 1992, 1993, 1994, 1995, 1996, 1997, 1998 Free Software Foundation, Inc.
-#
+# Copyright (C) 1990-1999 Free Software Foundation, Inc.
+#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2, or (at your option)
# any later version.
-#
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with this software; see the file COPYING. If not, write to
-# the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
+# the Free Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111, USA.
#
# As a special exception, the Free Software Foundation gives permission
# for additional uses of the text contained in its release of GUILE.
@@ -36,71 +36,56 @@
#
# If you write modifications of your own for GUILE, it is your choice
# whether to permit this exception to apply to your modifications.
-# If you do not wish that, delete this exception notice.
+# If you do not wish that, delete this exception notice.
-# "Makefile" for scm5c3 Scheme Interpreter
+# "Makefile" for scm Scheme Interpreter
# Author: Aubrey Jaffer
SHELL = /bin/sh
+CPROTO = cproto
#CC =
-CFLAGS = -g
+CFLAGS = -g -O
#LIBS =
-LD = $(CC) -g
+LD = $(CC) -g -O
-# directory where COPYING and Init5c3.scm reside.
+# directory where COPYING and InitXXX.scm reside.
#IMPLPATH = /usr/local/src/scm/
#this one is good for bootstrapping
IMPLPATH = `pwd`/
-# Pathname where Init5c3.scm resides.
-IMPLINIT = $(IMPLPATH)Init5c3.scm
-DFLAG = -DIMPLINIT=\"$(IMPLINIT)\"
+# Pathname where InitXXX.scm resides.
+include patchlvl.h
+IMPLINIT = $(IMPLPATH)Init$(VERSION).scm
-# If pathname where Init5c3.scm resides is not known in advance then
+# If pathname where InitXXX.scm resides is not known in advance then
# SCM_INIT_PATH is the environment variable whose value is the
-# pathname where Init5c3.scm resides.
+# pathname where InitXXX.scm resides.
intro:
@echo
- @echo "This is scm$(VERSION). Read \"scm.info\" (from \"scm.texi\")"
- @echo "to learn how to build and install SCM."
- @echo "Here is a quick guide:"
- @echo
- @echo " From: bos@scrg.cs.tcd.ie"
- @echo " Build and install scripts using GNU autoconf are"
- @echo " available as scmconfig.tar.gz in the SCM distribution"
- @echo " directories. See README.unix in scmconfig.tar.gz for"
- @echo " further instructions."
- @echo
- @echo " Alternatively:"
- @echo " make scmlit"
- @echo
- @echo " If you are on a non-unix system, create an empty file"
- @echo " \"scmflags.h\". Then compile time.c, repl.c, scl.c,"
- @echo " sys.c, eval.c, subr.c, unif.c, and rope.c. Then link"
- @echo " them to create a \"scmlit\" executable."
- @echo
- @echo " Once you have built scmlit successfully, test it:"
- @echo " make checklit"
- @echo " If this reports no errors, use scmlit to build"
- @echo " fancier versions of scm, with optional features."
-
-cfiles = scm.c time.c repl.c ioext.c scl.c sys.c eval.c subr.c sc2.c \
- unif.c rgx.c crs.c dynl.c record.c posix.c socket.c unix.c \
- rope.c ramap.c gsubr.c edline.c Iedline.scm continue.c \
+ @echo "This is the scm$(VERSION) distribution. Read \"scm.info\""
+ @echo "to learn how to build and install SCM. Or browse"
+ @echo " http://swissnet.ai.mit.edu/~jaffer/SCM.html"
+
+cfiles = scmmain.c scm.c time.c repl.c ioext.c scl.c sys.c eval.c \
+ subr.c sc2.c unif.c rgx.c crs.c dynl.c record.c posix.c socket.c\
+ unix.c rope.c ramap.c gsubr.c edline.c Iedline.scm continue.c \
findexec.c script.c
-ofiles = time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \
+ofiles = scm.o time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \
continue.o findexec.o script.o
# ramap.o
-ifiles = Init5c3.scm Transcen.scm Link.scm Macro.scm
-
-all:
- make mydlls
- make myscm
-scmlit: $(ofiles) scm.o
- $(LD) -o scmlit $(ofiles) scm.o $(LIBS)
- make checklit
-scm.o: scm.c scm.h scmfig.h patchlvl.h scmflags.h
- $(CC) $(CFLAGS) -c $(DFLAG) scm.c
+ifiles = Init$(VERSION).scm Transcen.scm Link.scm Macro.scm Macroexpand.scm \
+ Tscript.scm
+xfiles = x.c x.h xgen.scm xevent.scm xevent.h inc2scm x11.scm
+
+all: require.scm
+ $(MAKE) mydlls
+ $(MAKE) myscm
+require.scm:
+ cp -p requires.scm require.scm
+
+scmlit: $(ofiles) scmmain.o require.scm
+ $(LD) -o scmlit $(ofiles) scmmain.o $(LIBS)
+ $(MAKE) checklit
scmflags.h: scmflags
scmflags:
echo "#ifndef IMPLINIT" > newflags.h
@@ -111,6 +96,8 @@ scmflags:
.c.o:
$(CC) -c $(CFLAGS) $< -o $@
+scm.o: scm.c scm.h scmfig.h scmflags.h patchlvl.h
+scmmain.o: scmmain.c scm.h scmfig.h scmflags.h patchlvl.h
scl.o: scl.c scm.h scmfig.h scmflags.h
eval.o: eval.c scm.h scmfig.h scmflags.h setjump.h
unif.o: unif.c scm.h scmfig.h scmflags.h
@@ -121,48 +108,66 @@ time.o: time.c scm.h scmfig.h scmflags.h
subr.o: subr.c scm.h scmfig.h scmflags.h
rope.o: rope.c scm.h scmfig.h scmflags.h
continue.o: continue.c continue.h setjump.h scmflags.h
- $(CC) $(CFLAGS) -c continue.c
srcdir=$(HOME)/scm/
udscm4: $(cfiles) $(hfiles) build.scm build
- $(srcdir)build -hsystem -o udscm4 -Fcautious \
+ $(srcdir)build -hsystem -o udscm4 -s $(IMPLPATH) -Fcautious \
bignums arrays inexact engineering-notation dump dynamic-linking
+ rm $(ofiles) scmmain.o
udscm5: $(cfiles) $(hfiles) build.scm build
- $(srcdir)build -hsystem -o udscm5 -Fcautious \
+ $(srcdir)build -hsystem -o udscm5 -l debug -s $(IMPLPATH) -Fcautious \
bignums arrays inexact engineering-notation dump dynamic-linking \
macro #-DNO_SYM_GC
+ rm $(ofiles) scmmain.o
-myscm4: udscm4 $(ifiles)
+myscm4: udscm4 $(ifiles) require.scm
-rm slibcat implcat
-mv scm scm~
echo "(quit)" | ./udscm4 -no-init-file -o scm
-myscm: udscm5 $(ifiles)
+myscm: udscm5 $(ifiles) require.scm
-rm slibcat implcat
-mv scm scm~
echo "(quit)" | ./udscm5 -no-init-file -r5 -o scm
- make check
+ $(MAKE) check
-mylib:
+mylib: libscm.a
+libscm.a:
$(srcdir)build -hsystem -Fcautious bignums arrays inexact \
- engineering-notation dump dynamic-linking -tlib
+ dynamic-linking -t lib
+libtest: libscm.a libtest.c
+ gcc -o libtest libtest.c libscm.a -ldl -lm -lc
+ ./libtest
pgscm:
- $(srcdir)build -hsystem -Fcautious bignums arrays inexact \
- engineering-notation dump dynamic-linking -o udscm \
- --compiler-options=-pg --linker-options=-pg
+ $(srcdir)build -hsystem -s $(IMPLPATH) -Fcautious bignums arrays \
+ inexact engineering-notation dump dynamic-linking -o udscm \
+ --compiler-options=-pg --linker-options=-pg -DLACK_SETITIMER
echo "(quit)" | ./udscm -no-init-file -o pgscm
mydebug:
- $(srcdir)build -hsystem -oudgdbscm -F cautious \
+ $(srcdir)build -hsystem -oudgdbscm -s $(IMPLPATH) -F cautious \
bignums arrays inexact engineering-notation dump dynamic-linking \
macro \
debug --compiler-options=-Wall --linker-options=-Wall #-DTEST_FARLOC
echo "(quit)" | ./udgdbscm -no-init-file -r5 -o gdbscm
-mydlls:
- $(srcdir)build -h system -t dll -c sc2.c rgx.c crs.c edline.c \
- record.c gsubr.c ioext.c posix.c unix.c socket.c \
- ramap.c
+
+incdir=/usr/include/
+x11.scm: inc2scm Makefile
+ rm -f x11.scm
+ ./inc2scm x11.scm x: $(incdir) X11/X.h X11/cursorfont.h X11/Xlib.h X11/Xutil.h
+xevent.h: xgen.scm
+ ./xgen.scm $(incdir)X11/Xlib.h
+x.h: x.c xevent.h
+ $(CPROTO) x.c > x.h
+x.so: x.c x.h xevent.h
+ $(srcdir)build -h system -Fx -t dll --compiler-options=-Wall
+mydlls: x.so
+ if [ -f /usr/lib/libreadline.so ]; \
+ then $(srcdir)build -h system -Fedit-line -t dll;fi
+ $(srcdir)build -h system -Fcurses -t dll
+ $(srcdir)build -h system -t dll -c sc2.c rgx.c record.c gsubr.c \
+ ioext.c posix.c unix.c socket.c ramap.c
myturtle:
$(srcdir)build -h system -F turtlegr -t dll
@@ -198,23 +203,45 @@ benchlit:
echo
tail -20 BenchLog
report:
- scmlit -e"(slib:report #t)"
+ ./scmlit -e"(slib:report #t)"
scm -e"(slib:report #t)"
dvidir=../dvi/
-dvi: $(dvidir)scm.dvi
-$(dvidir)scm.dvi: $(srcdir)scm.texi $(dvidir)scm.fn Makefile
+dvi: $(dvidir)scm.dvi $(dvidir)Xlibscm.dvi
+$(dvidir)scm.dvi: version.txi scm.texi platform.txi features.txi\
+ $(dvidir)scm.fn Makefile
# cd $(dvidir);export TEXINPUTS=$(srcdir):;texi2dvi $(srcdir)scm.texi
-(cd $(dvidir);export TEXINPUTS=$(srcdir):;texindex scm.??)
cd $(dvidir);export TEXINPUTS=$(srcdir):;tex $(srcdir)scm.texi
$(dvidir)scm.fn:
cd $(dvidir);export TEXINPUTS=$(srcdir):;tex $(srcdir)scm.texi
+$(dvidir)Xlibscm.dvi: version.txi Xlibscm.texi \
+ $(dvidir)Xlibscm.fn Makefile
+# cd $(dvidir);export TEXINPUTS=$(srcdir):;texi2dvi $(srcdir)Xlibscm.texi
+ -(cd $(dvidir);export TEXINPUTS=$(srcdir):;texindex Xlibscm.??)
+ cd $(dvidir);export TEXINPUTS=$(srcdir):;tex $(srcdir)Xlibscm.texi
+$(dvidir)Xlibscm.fn:
+ cd $(dvidir);export TEXINPUTS=$(srcdir):;tex $(srcdir)Xlibscm.texi
xdvi: $(dvidir)scm.dvi
xdvi -s 6 $(dvidir)scm.dvi
+Xdvi: $(dvidir)Xlibscm.dvi
+ xdvi -s 6 $(dvidir)Xlibscm.dvi
+
htmldir=../public_html/
-html: $(htmldir)scm_toc.html
-$(htmldir)scm_toc.html: $(srcdir)scm.texi
- cd $(htmldir);make scm_toc.html
+html: $(htmldir)scm_toc.html $(htmldir)Xlibscm_toc.html
+
+scm_toc.html: version.txi scm.texi platform.txi features.txi
+ texi2html -split -verbose scm.texi
+Xlibscm_toc.html: $(htmldir)Xlibscm_toc.html
+$(htmldir)Xlibscm_toc.html: version.txi Xlibscm.texi
+ cd $(htmldir);texi2html -split -verbose $(srcdir)Xlibscm.texi
+
+scmprev/scm_toc.html:
+# cd scmprev;make scm_toc.html
+ cd scmprev;texi2html -split -verbose scm.texi
+
+$(htmldir)scm_toc.html: scmprev/scm_toc.html scm_toc.html Makefile
+ hitch scmprev/scm_\*.html scm_\*.html $(htmldir)
################ INSTALL DEFINITIONS ################
@@ -223,30 +250,64 @@ exec_prefix = $(prefix)
# directory where `make install' will put executable.
bindir = $(exec_prefix)bin/
libdir = $(exec_prefix)lib/
+libscmdir = $(libdir)scm/
# directory where `make install' will put manual page.
-man1dir = $(prefix)man/man1/
+mandir = $(prefix)man/
+man1dir = $(mandir)man1/
infodir = $(prefix)info/
includedir = $(prefix)include/
-info: $(infodir)/scm.info
-$(infodir)/scm.info: scm.texi
- makeinfo scm.texi -o $(infodir)/scm.info
- install-info $(infodir)/scm.info $(infodir)/dir
- -rm $(infodir)/scm.info*.gz
-
-infoz: $(infodir)/scm.info.gz
-$(infodir)/scm.info.gz: $(infodir)/scm.info
- gzip -f $(infodir)/scm.info*
+README: build build.scm scm.info
+ scm -l build -e"(make-readme)"
+
+info: installinfo
+installinfo: $(infodir)scm.info $(infodir)Xlibscm.info
+
+platform.txi: build.scm
+ ./scmlit -r database-browse -l build.scm -e "(browse build 'platform)" \
+ > platform.txi
+features.txi: build.features build.scm
+ ./scmlit -l build.features -e"(make-features-txi)"
+scm$(VERSION).info: version.txi scm.texi platform.txi features.txi
+ -mv scm.info scmtemp.info
+ makeinfo scm.texi --no-split -o scm.info
+ mv scm.info scm$(VERSION).info
+ -mv scmtemp.info scm.info
+scm.info: scm$(VERSION).info
+# infobar scmprev/scm.info scm$(VERSION).info scm.info
+$(infodir)scm.info: scm.info
+ cp -p scm.info $(infodir)scm.info
+ -install-info $(infodir)scm.info $(infodir)dir
+ -rm $(infodir)scm.info.gz
+
+Xlibscm.info: version.txi Xlibscm.texi
+ makeinfo Xlibscm.texi --no-split -o Xlibscm.info
+$(infodir)Xlibscm.info:
+ cp Xlibscm.info $(infodir)Xlibscm.info
+ -install-info $(infodir)Xlibscm.info $(infodir)/dir
+ -rm $(infodir)Xlibscm.info*.gz
+
+infoz: installinfoz
+installinfoz: $(infodir)scm.info.gz $(infodir)Xlibscm.info.gz
+$(infodir)scm.info.gz: $(infodir)scm.info
+ gzip -f $(infodir)scm.info
+$(infodir)Xlibscm.info.gz: $(infodir)Xlibscm.info
+ gzip -f $(infodir)Xlibscm.info
install: scm.1
test -d $(bindir) || mkdir $(bindir)
+ test -d $(mandir) || mkdir $(mandir)
test -d $(man1dir) || mkdir $(man1dir)
-cp scm $(bindir)
# -strip $(bindir)scm
-cp scm.1 $(man1dir)
- test -d $(IMPLPATH) || mkdir $(IMPLPATH)
- -cp Init5c3.scm Link.scm Transcen.scm Macro.scm COPYING $(IMPLPATH)
- -cp mkimpcat.scm Iedline.scm *.sl *.so $(IMPLPATH)
+ test -d $(libdir) || mkdir $(libdir)
+ test -d $(libscmdir) || mkdir $(libscmdir)
+ -cp Init$(VERSION).scm Link.scm Transcen.scm Macro.scm Tscript.scm \
+ COPYING $(libscmdir)
+ test -f $(libscmdir)require.scm || \
+ cp requires.scm $(libscmdir)require.scm
+ -cp mkimpcat.scm Iedline.scm *.sl *.so $(libscmdir)
installlib:
test -d $(includedir) || mkdir $(includedir)
@@ -261,26 +322,29 @@ uninstall:
-rm $(includedir)scm.h
-rm $(includedir)scmfig.h
-rm $(libdir)libscm.a
-# -rm $(IMPLPATH)Init5c3.scm
-# -rm $(IMPLPATH)Link.scm
-# -rm $(IMPLPATH)Transcen.scm
-# -rm $(IMPLPATH)COPYING
+# -rm $(libscmdir)Init$(VERSION).scm
+# -rm $(libscmdir)Link.scm
+# -rm $(libscmdir)Transcen.scm
+# -rm $(libscmdir)COPYING
scm.doc: scm.1
nroff -man $< | ul -tunknown >$@
#### Stuff for maintaining SCM below ####
-include patchlvl.h
ver = $(VERSION)
+version.txi: patchlvl.h
+ echo @set SCMVERSION $(VERSION) > version.txi
+ echo @set SCMDATE `date +"%B %Y"` >> version.txi
+
RM_R = rm -rf
ufiles = pre-crt0.c ecrt0.c gmalloc.c unexec.c unexelf.c unexhp9k800.c \
- unexsunos4.c unexalpha.c
+ unexsunos4.c unexalpha.c unexsgi.c
# cxux-crt0.s ecrt0.c gmalloc.c pre-crt0.c unexaix.c unexalpha.c \
# unexapollo.c unexconvex.c unexec.c unexelf.c unexelf1.c \
# unexencap.c unexenix.c unexfx2800.c unexhp9k800.c unexmips.c \
-# unexnext.c unexnt.c unexsgi.c unexsni.c unexsunos4.c
+# unexnext.c unexnt.c unexsgi.c unexsni.c unexsunos4.c
confiles = scmconfig.h.in mkinstalldirs acconfig-1.5.h install-sh \
configure configure.in Makefile.in COPYING README.unix
@@ -288,14 +352,16 @@ confiles = scmconfig.h.in mkinstalldirs acconfig-1.5.h install-sh \
hfiles = scm.h scmfig.h setjump.h patchlvl.h continue.h
tfiles = r4rstest.scm example.scm pi.scm pi.c split.scm bench.scm
dfiles = ANNOUNCE README COPYING scm.1 scm.doc QUICKREF \
- scm.texi ChangeLog
-mfiles = Makefile build.scm build build.bat .gdbinit mkimpcat.scm disarm.scm
+ scm.info scm.texi Xlibscm.info Xlibscm.texi ChangeLog
+mfiles = Makefile build.scm build build.bat requires.scm \
+ .gdbinit mkimpcat.scm disarm.scm
vfiles = setjump.mar setjump.s
afiles = $(dfiles) $(cfiles) $(hfiles) $(ifiles) $(tfiles) $(mfiles) \
- $(vfiles) $(ufiles)
+ $(vfiles) $(ufiles) $(xfiles)
makedev = make -f $(HOME)/makefile.dev
CHPAT=$(HOME)/bin/chpat
+RSYNC=rsync -v --rsync-path bin/rsync
dest = $(HOME)/dist/
temp/scm: $(afiles)
-$(RM_R) temp
@@ -304,15 +370,30 @@ temp/scm: $(afiles)
ln $(afiles) temp/scm
release: dist
- rsync -v $(htmldir)SCM.html martigny.ai.mit.edu:public_html/
- rsync -v $(dest)README $(dest)scm$(VERSION).tar.gz martigny.ai.mit.edu:dist/
- upload $(dest)README $(dest)scm$(VERSION).tar.gz prep.ai.mit.edu:gnu/jacal/
+ cp $(srcdir)ANNOUNCE $(htmldir)SCM_ANNOUNCE
+ $(RSYNC) $(htmldir)SCM.html $(htmldir)SCM_ANNOUNCE nestle.ai.mit.edu:public_html/
+ $(RSYNC) $(dest)README $(dest)scm$(VERSION).zip nestle.ai.mit.edu:dist/
+# upload $(dest)README $(dest)scm$(VERSION).zip ftp.gnu.org:gnu/jacal/
+# $(MAKE) indiana
+indiana:
+ upload $(dest)scm$(VERSION).zip ftp@ftp.cs.indiana.edu:/pub/scheme-repository/incoming
+ echo -e \
+ 'I have uploaded scm$(VERSION).zip to ftp.cs.indiana.edu:/pub/scheme-repository/incoming\n' \
+ 'for placement into ftp.cs.indiana.edu:/pub/scheme-repository/imp/' \
+ | mail -s 'SCM upload' -b jaffer scheme-repository-request@cs.indiana.edu
+
+postnews:
+ echo -e "Newsgroups: comp.lang.scheme\n" | cat - ANNOUNCE | \
+ inews -h -O -S \
+ -f "announce@docupress.com (Aubrey Jaffer & Radey Shouman)" \
+ -t "SCM$(VERSION) Released" -d world
+
upzip: $(HOME)/pub/scm.zip
- rsync -v $(HOME)/pub/scm.zip martigny.ai.mit.edu:pub/
+ $(RSYNC) $(HOME)/pub/scm.zip nestle.ai.mit.edu:pub/
-dist: $(dest)scm$(VERSION).tar.gz
-$(dest)scm$(VERSION).tar.gz: temp/scm
- $(makedev) DEST=$(dest) PROD=scm ver=$(VERSION) tar.gz
+dist: $(dest)scm$(VERSION).zip
+$(dest)scm$(VERSION).zip: temp/scm
+ $(makedev) DEST=$(dest) PROD=scm ver=$(VERSION) zip
cvs tag -F scm$(VERSION)
shar: scm.shar
scm.shar: temp/scm
@@ -324,12 +405,12 @@ scm.com: temp/scm
zip: scm.zip
scm.zip: temp/scm
$(makedev) PROD=scm zip
-distzip: scm$(VERSION).zip
-scm$(VERSION).zip: temp/scm turtle turtlegr.c grtest.scm require.scm
- $(makedev) DEST=$(dest) PROD=scm ver=$(VERSION) zip
- cd ..; zip -9ur $(dest)scm$(VERSION).zip \
- scm/turtle scm/turtlegr.c scm/grtest.scm scm/require.scm
- mv $(dest)scm$(VERSION).zip /c/scm/dist/
+doszip: /c/scm/dist/scm$(VERSION).zip
+/c/scm/dist/scm$(VERSION).zip: temp/scm turtle turtlegr.c grtest.scm
+ $(makedev) DEST=/c/scm/dist/ PROD=scm ver=$(VERSION) zip
+ cd ..; zip -9ur /c/scm/dist/scm$(VERSION).zip \
+ scm/turtle scm/turtlegr.c scm/grtest.scm
+ zip -d /c/scm/dist/scm$(VERSION).zip scm/scm.info scm/Xlibscm.info
pubzip: $(HOME)/pub/scm.zip
$(HOME)/pub/scm.zip: temp/scm
$(makedev) DEST=$(HOME)/pub/ PROD=scm zip
@@ -341,7 +422,7 @@ distdiffs: temp/scm
$(makedev) DEST=$(dest) PROD=scm ver=$(ver) distdiffs
-HOBBITVERSION = 4d
+HOBBITVERSION = 5x
hobfiles = README.hob hobbit.doc hobbit.tms hobbit.scm scmhob.h
#hobfiles = hobbit.doc COPYING Makefile.hob hobbit.scm scmhob.h scmhob.scm
@@ -351,12 +432,12 @@ hobtemp/scm: $(hobfiles)
mkdir hobtemp/scm
ln $(hobfiles) hobtemp/scm
-hobdist: $(dest)hobbit$(HOBBITVERSION).tar.gz
-$(dest)hobbit$(HOBBITVERSION).tar.gz: hobtemp/scm
+hobdist: $(dest)hobbit$(HOBBITVERSION).zip
+$(dest)hobbit$(HOBBITVERSION).zip: hobtemp/scm
$(makedev) DEST=$(dest) PROD=scm ver=-hob$(HOBBITVERSION) \
- tar.gz TEMP=hobtemp/
- mv $(dest)scm-hob$(HOBBITVERSION).tar.gz \
- $(dest)hobbit$(HOBBITVERSION).tar.gz
+ zip TEMP=hobtemp/
+ mv $(dest)scm-hob$(HOBBITVERSION).zip \
+ $(dest)hobbit$(HOBBITVERSION).zip
hobbit$(HOBBITVERSION).zip: hobtemp/scm
$(makedev) TEMP=hobtemp/ name=hobbit$(HOBBITVERSION) PROD=scm zip
@@ -374,19 +455,17 @@ new:
$(htmldir)SCM.html $(htmldir)Hobbit.html \
$(htmldir)SIMSYNCH.html \
/c/scm/dist/install.bat /c/scm/dist/makefile \
- /c/scm/dist/mkdisk.bat README
+ /c/scm/dist/mkdisk.bat hobbit.doc
+ cp -f hobbit.doc $(htmldir)hobbit.txt
mv -f Init$(VERSION).scm Init$(ver).scm
- $(CHPAT) $(VERSION) $(ver) scm.texi patchlvl.h \
- Init$(ver).scm $(htmldir)SCM.html Makefile
+ $(CHPAT) $(VERSION) $(ver) patchlvl.h \
+ Init$(ver).scm $(htmldir)SCM.html
cvs remove Init$(VERSION).scm
cvs add Init$(ver).scm
cvs commit -m 'Init$(VERSION).scm changed to Init$(ver).scm' \
Init$(VERSION).scm Init$(ver).scm
cvs commit -m '(SCMVERSION): Bumped from $(VERSION) to $(ver).'
cvs tag -F scm$(ver)
- if [ -L Init.scm ]; then rm -f Init.scm; else \
- mv -f Init.scm Init.scm~; fi
- ln -s Init$(ver).scm Init.scm
configtemp/scm: $(confiles)
-$(RM_R) configtemp/scm
@@ -426,19 +505,23 @@ name8s: scmlit
}else p=1;\
l=$$1\
}END{exit stat}' -
-ctags: $(hfiles) $(cfiles)
- etags $(hfiles) $(cfiles)
+ctags: $(hfiles) $(cfiles) $(xfiles)
+ etags $(hfiles) $(cfiles) $(xfiles)
TAGS:
-tags: $(hfiles) $(cfiles) $(ifiles) $(vfiles) $(ufiles)\
- scm.texi README build.scm # $(mfiles) ChangeLog hobbit.scm
- etags $(hfiles) $(cfiles) $(ifiles) $(vfiles) $(ufiles)\
- scm.texi README build.scm # $(mfiles) ChangeLog hobbit.scm
+tags: $(hfiles) $(cfiles) $(ifiles) $(vfiles) turtlegr.c\
+ version.txi scm.texi Xlibscm.texi build.scm build $(xfiles)
+# # $(ufiles) $(mfiles) ChangeLog hobbit.scm
+ etags $(hfiles) $(cfiles) $(ifiles) $(vfiles) turtlegr.c\
+ Xlibscm.texi scm.texi build.scm build $(xfiles)
+# # $(ufiles) $(mfiles) ChangeLog hobbit.scm
mostlyclean:
clean:
- -rm -f core a.out ramap.o ramap.obj $(ofiles) scm.o lints
+ -rm -f core a.out ramap.o ramap.obj $(ofiles) scmmain.o lints
-$(RM_R) *temp
+ -rm -f scm$(VERSION).info
+
distclean: clean
- -rm -f $(EXECFILES) *.o *.obj a.out TAGS implcat slibcat gdbscm
+ -rm -f $(EXECFILES) *.o *.obj a.out implcat slibcat gdbscm TAGS
realclean: distclean
-rm -f scm.doc
realempty: temp/scm