aboutsummaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog588
1 files changed, 588 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 1555342..d125dfb 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,591 @@
+2015-01-14 Aubrey Jaffer <jaffer@dv7t>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5f1 to 5f2.
+
+2015-01-03 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (int2dbl, pmantexp2dbl): Recycle temporary bignums.
+
+2014-11-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pdbl2str, pmantexp2dbl): Cleaned up code.
+
+2014-11-22 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pmantexp2dbl): Handle exponents smaller than -324.
+ (pmantexp2dbl): Optimized. Added bigrecy(quo).
+ (pdbl2str, pmantexp2dbl): Uses powers-of-5.
+
+2014-11-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pmantexp2dbl): call int2dbl() instead of num2dbl().
+ (pdbl2str): Use powers-of-5 table instead of powers-of-10.
+ (pdbl2str): e2 > 0 prints out extra digit; reverting.
+
+2014-05-04 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (strrecy, pdbl2str): Recycle temporary string used in
+ number->string conversion.
+ (scm_intexpt): Call bigrecy only when #ifdef BIGDIG.
+
+2014-05-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * subr.c (scm_bitwise_bit_count, scm_logcount, scm_intlength)
+ (big2inum): Recycle temporary bignums.
+
+ * scl.c (int2dbl, scm_intexpt, divide, difference, big2str)
+ (pdbl2str): Recycle temporary bignums.
+
+2014-04-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (bigrecy): Added procedure to recycle bignums.
+ (mantexp2dbl, pmantexp2dbl, int2dbl): Recycle temporary bignums.
+
+ * r4rstest.scm (test-bignum): Added tests for GCD and LCM.
+
+2014-04-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * sys.c (sysptob): Added sysflush (for sys_errp). Fixed exit when
+ verbose > 3.
+
+ * scm.c (process_signals): Reenabled lfflush(sys_errp).
+
+2014-04-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Internal State): Added "(gc #t)".
+
+2014-04-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pdbl2str): Replaced call to int2dbl() with scm_intlength().
+
+2014-02-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi: TeXinfo-5 now disallows text between @defunx lines.
+
+2014-02-08 From: Marc Espie
+
+ * time.c: OpenBSD is phasing out old interfaces such as ftime and
+ the timeb data structure. This should allow things to work in a
+ saner way on any system that uses gettimeofday().
+
+2013-05-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5e7 to 5f1.
+
+2013-04-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (test-inexact-printing): Added float-rw-range-test
+ to check that all powers of 10 in the range of IEEE doubles are
+ read-write-invariant and their strings are short.
+
+2013-04-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pmantexp2dbl): Renamed from imantexp2dbl and radically
+ simplified (because bex < 0).
+
+2013-04-12 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_intexpt): Fixed (integer-expt 2 -1074).
+ (dbl2big): Was returning unnormalized bignums.
+
+2013-04-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (llog2): Use with bignums also.
+
+2013-04-06 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scmfig.h (BIGDIG): Enable 32-bit BIGDIGs.
+
+ * subr.c (scm_big_ash): Workaround left-shifting unsigned int by
+ 32-bits in gcc -O0 bug.
+
+ * scl.c: Removed debugging printf()s.
+
+ * dynl.c, eval.c, repl.c, scmmain.c (scm_verbose): Replaced uses
+ of `verbose' alias.
+
+2013-03-31 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scmfig.h: Rearranged to enable detection of int size.
+
+ * subr.c (scm_bitfield, scm_ash): Don't reuse SCM variables as longs.
+
+2013-03-30 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (ilong2str): Renamed from iint2str().
+ (pdbl2str): No longer assumes that ulong is larger than double.
+
+ * subr.c (divbigdig): Return type changed to UBIGLONG.
+
+2013-03-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.h (iuint2str): Added declaration.
+
+ * scmfig.h (UBIGLONG, SBIGLONG): Added in preparation for 32-bit
+ BIDIG.
+
+ * bytenumb.c (scm_bytes_to_integer, scm_integer_to_bytes): Use
+ UBIGLONG for integers holding 2 BIGDIGs.
+
+ * scl.c (int2dbl): Only accumulate dbl_mant_dig worth of BIGDIGs.
+ (dbl2big, int2dbl): Use ldexp() instead of multiplication by BIGRAD.
+ (pdbl2str): Use unsigned int2str conversion.
+ (istr2int): Changed radix from long to int.
+
+ * subr.c (divbigbig): Implements core of scm_round_quotient().
+ (divbigbig): Round correctly when x is shorter than y.
+ (scm_copy_big_ash1): Abstracted repeated code from divbigbig().
+ (scm_big_ash, big2inum, long2big, addbig, mulbig)
+ (divbigdig, divbigint, divbigbig): Use UBIGLONG and SBIGLONG for
+ integers holding 2 BIGDIGs.
+
+2013-03-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * subr.c (scm_round_quotient): Round toward even.
+
+2013-03-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (imantexp2dbl): Added to check that conversion to decimal
+ is accurate.
+ (pdbl2str): Uses smallest number of digits!
+
+ * subr.c (scm_round_quotient): Abstracted from decimal conversion
+ code and int2dbl().
+
+2013-03-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (int2dbl): Renamed from big2dbl.
+ (inex_divintbig): Renamed from inex_divbigbig.
+ (big2scaldbl): Removed for not returning unnormalized doubles.
+ (divide, inex_divintbig): Can now return unnormalized doubles.
+
+2013-03-09 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (scm4, scm5, dscm5): Don't ignore (readback) errors.
+
+ * scl.c (mantexp2dbl, big2dbl): Comment out checks for rounding
+ evenness making a difference.
+
+ * r4rstest.scm (test-inexact): Changed 4.0 to f4.0.
+
+ * scl.c (mantexp2dbl): Reading now accurate for negative
+ exponents. Only one readback error remains: 699.99999999998702e18
+ (big2dbl): Turned out to need explicit rounding -- all are fixed!
+
+2013-02-20 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pdbl2str): Does engineering notation now.
+
+2013-02-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (pdbl2str): Replaced with homegrown version.
+ (pdbl2str): Fixed nasty range error around 2.^53.
+ Still failing 12 readback tests; too many digits output.
+
+2013-02-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (test-inexact-printing): Output both original and
+ readback value.
+
+ * scl.c (pdbl2str): Implements "Printing Floating-Point Numbers
+ Quickly and Accurately" by Robert G. Burger and R. Kent Dybvig.
+ 1.000000000000001 doesn't seem right.
+
+2013-01-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (dbl_prec, apx_log10, lpow10): Moved adjacent to
+ pdbl2str(), which is their only use.
+
+2013-01-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_cintlog): Fixed eqv reference in scmlit build.
+
+2013-01-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_next_dfloat): Removed (skipped codes).
+ (pdbl2str): Split from idbl2str() in preparation for improved
+ printing of floats.
+
+2013-01-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_intlog, integer-log): Ported to C.
+ * (ceiling-integer-log): Ported to C for use in printing floats.
+
+2013-01-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (mantexp2dbl): Fixed reading of small magnitude numbers;
+ seem to be no missing codes from ieee-double->bytes.
+
+2013-01-01 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (istr2flo): Convert '#' to '0' in mantissa string.
+ (mantexp2dbl): Fixed reading of large magnitude numbers!
+ (dbl2big): Don't loop forever on infinite arguments.
+
+2012-12-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (mantexp2dbl): Separated mantissa conversion and scaling
+ from istr2flo().
+
+2012-12-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * bytenumb.c (get_bytes): Fixed bytes-length checking.
+
+2012-12-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile: Removed turtlegr files from distribution because
+ copyright isn't assigned to FSF.
+
+ * findexec.c: Copyright was assigned to FSF.
+
+2012-08-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * eval.c (m_body): Reverse letrec bindings (and internal defines)
+ to produce LETREC* behavior.
+
+2012-04-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (upgnu): Added target to upload to ftp.gnu.org.
+
+2012-01-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Init5e7.scm (integer->list): Negative k not allowed.
+
+2011-12-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (catfiles): Create catalogs at end of install and
+ remove in uninstall.
+
+2011-12-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (install-lib): Install $(wbfiles) if -f wbscm.so.
+
+2011-12-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (install-lib): Install "build" as program.
+
+2011-11-24 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Testing): Moved between "Problems Linking" and
+ "Problems Starting".
+
+2011-11-20 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (install-lib): Make installation of libscm.a optional.
+
+ * scm.texi (Distributions, GNU configure and make): Added text
+ suggested by John Gabriele.
+
+2011-11-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * lastfile.c: Fixed typo ("macosx-config.h").
+
+2011-11-12 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi, README (Installing SCM): Reorganized and expanded.
+
+ * Makefile (SETARCH): Use for disabling OS-X dump-time ASLR.
+ (udscm*.opt scm*.opt): Refactored dependencies.
+
+2011-11-06 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (alld5, all5): Clever sub-targets of all.
+
+ * scm.texi (Building Using Make): Added subsection.
+
+2011-10-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Installing SCM): Reorganized in response to
+ suggestions from John Gabriele.
+
+2011-10-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Installing SCM): Reorganized.
+ Updated email addresses.
+
+ * Makefile (configure.usage): Added.
+
+2011-09-04 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (inf2str): Ouput +nan.0 for NaN.
+ (istr2flo): Parse [-+]nan.0.
+
+2011-08-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (istr2flo): 1e-1 ==> 100.0e-3; 1f-1 ==> 100.00000149011612e-3
+
+2011-08-05 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * unexmacosx.c: Added Emacs dump code for OS-X.
+
+ * x11.scm: Updated for X Server 1.9.0.
+
+2011-06-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (I/O-Extensions): Added DIRECTORY*-FOR-EACH.
+
+2011-03-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scmfig.h (__APPLE__): Include unistd.h.
+
+2010-10-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_bigdblcomp): Fixed type of argument to frexp().
+
+ * findexec.c (dld_find_executable): Handle getcwd() failure.
+
+ * sys.c (ltmpnam): Handle tmpnam() failure.
+
+ * unif.c (list->uniform-array): Fixed rank check.
+
+2010-10-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.h (tc7_VfixN64, tc7_VfixZ64): Added.
+
+ * scm.texi (Data Type Representations): Allocated codes for
+ tc7_VfixN64 and tc7_VfixZ64.
+
+2010-08-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * differ.c (I32): Workaround for A:fixZ32b actually being 64.bit
+ on __x86_64.
+
+ * rope.c (scm_addr, scm_base_addr): Changed return type to void*.
+
+2010-07-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Conventional Arrays): @exdent wide examples.
+
+ * Makefile (scm5, scm4): Fail if check fails.
+
+ * scl.c (inf2str): Use strcpy() instead of explicity copying.
+
+2010-06-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5e6 to 5e7.
+
+ * Makefile (winscm5.opt): Use wb-no-threads.
+
+ * build.scm (wb-no-threads): wb feature for mingw.
+
+ * hobbit.texi (Compiling And Linking): Fixed \" quoting in @example.
+
+ * Makefile, scm.spec: Fixed RPM build.
+
+2010-06-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile: INSTALL_INFO = ginstall-info.
+
+2010-06-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * configure: Improved portability of trailing / detection.
+
+ * Makefile (db.so): Added $(wbfiles) dependency.
+
+2010-05-22 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * configure (ac_default_prefix): Was lacking trailing /.
+
+2010-04-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (db.so): Recompile if any ../wb/c/*.c changes.
+ (tagfiles): Don't include documentation sources twice.
+ (x.h): CPROTO no longer available; "x.h" is in CVS.
+
+2010-03-31 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ioext.c (copy-file): Added.
+
+2010-03-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * hobbit.texi (Compiling And Linking): Fixed quoting in example
+ compile commands for MS-DOS prompt.
+
+2010-02-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (Makefile): Runs ./configure to create config.status.
+
+2010-02-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile: Reorganized per <http://www.gnu.org/prep/standards/>.
+
+2010-02-04 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * configure: GNU-style configuration for installation creates
+ config.status, which is included by Makefile.
+
+2010-01-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Numeric): Added infinite?, finite?, exact-round,
+ exact-floor, exact-ceiling, and exact-truncate.
+
+2009-12-27 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (Bit Vectors): Fixed doc for bit-set*!.
+
+2009-10-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ioext.c (init_ioext): Added directory*-for-each.
+
+2009-10-05 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (wb): Added c-lib pthread.
+ (C-libraries): pthread added.
+
+ * Makefile (db.so): Corrected for new WB file organization.
+
+2009-09-14 Radey Shouman <shouman@comcast.net>
+
+ * Macexp.scm (macro:expand-syntax): Fix non-pretty case.
+ Fully expand identifier macros.
+
+ * eval.c (scm_macroexpand1): Properly handle identifier macros.
+ (macroexp1): Fixed for the case of the first argument an
+ identifier -- used to return a list headed by #@quote.
+ (ceval_1): Fixed argument number check for nullary procedures --
+ used to incorrectly call scm_dynthrow.
+
+2009-08-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * dynl.c (l_dyn_main_call): Added cast to eliminate gcc warning.
+
+ * sys.c (free_storage): Removed late call to lfflush() which
+ caused segfault in fc9.
+
+ * mkimpcat.scm (in-wb-vicinity): is "../wb/c/".
+
+2009-08-26 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * sys.c (gc_mark): For tcs_cons_nimcar, do one CDR lookahead for
+ mark.
+
+2009-08-02 Aubrey Jaffer <jaffer@localhost.localdomain>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5e5 to 5e6.
+
+2009-07-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * ioext.c (make-directory): Fixed umask (to #o022).
+
+2009-03-21 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_bigdblcomp): Fixed comparison with infinities.
+ (scm_max, scm_min): Renamed from lmax, lmin.
+ (bigdblop): Fixed division by 0 and infinities.
+ (bigdblop): Fixed case: (/ (+ 1 most-positive-fixnum) 1e-165)
+
+2008-12-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (6 5 5): Added exact-integer division tests.
+
+2008-12-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (6 9): Added (procedure? /).
+ (4 2 4): Added test for test clause without expressions.
+
+2008-11-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (build:command): Comment interfered with make-build-cgi.
+
+2008-08-06 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * rope.c (scm_gc_protect): Don't check if already protected; for
+ large Hobbit compiles that is an O(N^2) process.
+
+ * hobbit.scm (make-initialization-function!): Sets no_symhash_gc.
+
+ * sys.c, scm.h (no_symhash_gc): Added for Hobbit-produced code.
+
+ * Link.scm (link:link): Added calls to load:pre and load:post.
+
+ * mkimpcat.scm (add-links): Added "hobbit.so".
+
+ * Init5e5.scm (load:pre, load:post): Take operation argument for
+ use with both loading and linking.
+
+2008-08-06 Martin Ward
+
+ * hobbit.scm (*c-keywords*): Added system, random, and exit.
+ (*char-replacements*): Added backslash.
+
+2008-07-27 Thomas Bushnell BSG
+
+ * build.scm (linux-ia64, build-continue-ia64): Include
+ continue-ia64.o in .a libraries.
+
+2008-07-05 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.texi (SCM Session): Added description of getenv (extension).
+
+ * scm.c (scm_getenv): Renamed from lgetenv; with no arguments,
+ returns names and values of all the environment variables as an
+ association-list.
+
+2008-06-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * sys.c (sfwrite, sfputs): Added "const" to first argument
+ declaration.
+
+2008-06-15 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scm.nsi: Added "Tscript.scm".
+
+2008-05-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * repl.c (wait_for_input): Removed restriction to input-ports.
+
+ * record.c (recprin1): Don't print field values unless
+ SCM_SHOW_RECORD_FIELDS; allows suffix-trees to print.
+
+2008-05-13 Radey Shouman <shouman@comcast.net>
+
+ * scm.c (ignore_signals): Added volatile assignment to
+ prevent scmable_signal function from being optimized
+ away - relevant only to windows builds.
+
+2008-03-11 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (istr2flo): +/, +/0, and 234/ are no longer numbers.
+
+ * sys.c (scm_portp): Added SLIB prerequisite.
+
+2008-02-25 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * inc2scm, xgen.scm: Changed first line to invoke ./scmlit.
+
+2008-02-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * continue.h (STACK_GROWS_UP): if __hppa__.
+
+ * scm.texi (Automatic C Preprocessor Definitions): Added __hppa__
+
+2008-02-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * mkimpcat.scm (add-source): Look for file with scheme-suffix.
+
+ * Makefile (xevent.h xevent.scm xatoms.scm):
+ (x11.scm, keysymdef.scm): Don't source include files from DESTDIR.
+
+2008-02-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * build.scm (compile-dll-c-files, compile-c-files): Added missing
+ '(include-spec "-I" parms)'.
+
+2008-02-13 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (lsdfiles): Removed duplicate "Iedline.scm".
+
+2008-02-10 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (texifiles): Moved definition before use.
+
+ * build.scm (compile-dll-c-files, make-dll-archive):
+ MACOSX_DEPLOYMENT_TARGET=10.3
+
+ * Makefile (all): Don't make db.so.
+ (lsdfiles): Removed WB files.
+ (afiles): Removed $(wbfiles).
+
2008-02-01 Aubrey Jaffer <jaffer@aubrey.jaffer>
* patchlvl.h (SCMVERSION): Bumped from 5e4 to 5e5.