aboutsummaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog166
1 files changed, 166 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index df2ebd4..8acdf96 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,169 @@
+2006-02-19 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (atanh, acosh, asinh): define if #ifndef HAVE_ATANH.
+
+ * scmfig.h (HAVE_ATANH): Decides whether atanh, asinh, and acosh
+ are supported.
+
+2006-02-16 Radey Shouman <shouman@comcast.net>
+
+ * scl.c: Changes to allow compilation with MinGW (gnu-win32);
+ asinh, acosh, and atanh are not yet supported.
+
+2006-02-13 Aubrey Jaffer <jaffer@aubrey>
+
+ * patchlvl.h (SCMVERSION): Bumped from 5e1 to 5e2.
+
+2006-02-08 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (lasinh, lacosh, latanh): Replaced by libc functions.
+
+2006-02-08 Steve VanDevender
+
+ * scmfig.h (SHORT_INT, CDR_DOUBLES): For __x86_64 (AMD Opteron).
+
+2006-01-23 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (exact-round, exact-floor, exact-ceiling)
+ (exact-truncate): Returned inexacts.
+
+2006-01-14 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (quo, rem, mod): New names for inexact quotient,
+ remainder, and modulo.
+
+ * scmfig.h (SCM_EXPECT_TRUE, SCM_EXPECT_FALSE): Added.
+ (POSFIXABLE, NEGFIXABLE, UNEGFIXABLE): SCM_EXPECT_TRUE.
+
+ * scm.h: SCM_EXPECT_TRUE and SCM_EXPECT_FALSE replace
+ __builtin_expect().
+ (ASRTER, ASRTGO): SCM_EXPECT_FALSE.
+
+ * scl.c (sum, difference, divide): Added BIGDIG* cast to &z.
+
+ * scmfig.h (__builtin_expect): Added stub for non-gcc compilers.
+
+ * scm.h (INUMP, IMP, SINGP): Added __builtin_expect() netting more
+ than 9% speed improvement in JACAL.
+
+ * Makefile (scm5.opt, udscm4.opt): Commented out
+ -fno-guess-branch-probability flag.
+
+2006-01-09 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (udscm4.opt, scm5.opt): Condition
+ -fno-guess-branch-probability on `type gcc'.
+
+2006-01-06 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * byte.c, continue.c, crs.c, dynl.c, eval.c, gsubr.c, ioext.c,
+ posix.c, ramap.c, record.c, repl.c, rope.c, sc2.c, scl.c, scm.c,
+ scm.h, socket.c, subr.c, sys.c, time.c, unif.c, unix.c, x.c:
+ Regularized `if' syntax.
+
+ * Makefile (scm5.opt, udscm4.opt): -fno-guess-branch-probability
+ improves benchmark speed 10% on i686.
+ (hfiles): Moved to top of file so that dependencies work.
+
+2006-01-04 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (numident): Don't bomb given bignums.
+
+ * scm.c (l_pause): __CYGWIN__ now has pause().
+
+ * scmfig.h (LACK_FTIME): __CYGWIN__ now has ftime().
+
+ * ioext.c: __CYGWIN__ has <unistd.h>.
+
+ * build.scm (build:command): Comment to script: [-p <platform>].
+
+2005-12-18 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * socket.c (l_lna, l_hostinfo, l_netinfo, l_setnet): Made
+ conditional on __CYGWIN__.
+
+2005-12-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (makdbl): (+ -1/0 +5i) ==> -1/0; not 0/0.
+
+2005-12-01 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scmmain.c, scm.h, scm.c, rope.c, repl.c: Added const decls.
+
+ * scl.c (apx_log10): Removed unused variable.
+
+2005-10-29 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (scm_magnitude): Renamed from magnitude().
+ (scm_abs): Added, real-only.
+
+ * subr.c (absval): Moved to scl.c.
+
+ * hobbit.scm (*c-keywords*): absval --> scm_abs; magnitude -->
+ scm_magnitude.
+
+ * rope.c, scm.c, scm.texi, scmmain.c, script.c, socket.c: Added
+ const to argv.
+
+ * Init5e1.scm (abs): Is no longer synonym for magnitude.
+
+2005-10-28 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Makefile (turfiles): Added turtle-graphics files.
+
+2005-10-27 Thomas Bushnell
+
+ * scm.doc, scm.1: Corrected spelling errors.
+
+2005-10-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * unexelf.c: Imported from emacs-22.0.50 to fix FC4 build.
+
+2005-09-22 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * rope.c (num2dbl): Handle 0/0.
+
+2005-08-16 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (exact-round, exact-floor, exact-ceiling)
+ (exact-truncate): Renamed from xxx->exact.
+ (limit): Removed.
+
+ * scl.c (inf2str): Changed to "+inf.0" and "-inf.0".
+ (istr2flo): Parse "+inf.0", "-inf.0", and
+ COMPACT_INFINITY_NOTATION.
+
+2005-08-07 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (round->exact, floor->exact, ceiling->exact,
+ truncate->exact): Added SRFI-70 convenience functions.
+
+ * differ.c (diff_mid_split): Unused `m' argument removed.
+
+2005-07-17 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * scl.c (safe_add_1): Replaces add1.
+ (scm_truncate): Renamed from ltrunc.
+
+ * scm.h (scm_truncate): Renamed from ltrunc.
+ (scm_floor, scm_ceiling): Added.
+
+2005-07-02 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * Transcen.scm (sequence->limit): Removed use of 1/0 literal.
+
+ * scl.c (inf2str): Prefix "1/0" with '+'.
+ (istr2flo, inf2str): COMPACT_INFINITY_NOTATION flag enables +/0
+ and -/0 infinity notations.
+
+2005-06-30 Aubrey Jaffer <agj@alum.mit.edu>
+
+ * r4rstest.scm (SECTION 6 5 5): Restored 0^0 test.
+
+ * Transcen.scm (expt): 0^0 ==> 1.
+
+ * scl.c (scm_intexpt): 0^0 ==> 1.
+
2005-06-25 Aubrey Jaffer <agj@alum.mit.edu>
* scm.spec (slibpath, dumparch): Added.