aboutsummaryrefslogtreecommitdiffstats
path: root/unexalpha.c
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2003-05-07 08:36:40 -0600
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commite21d47d7813159bb71e0671df9b52ec0470c358d (patch)
tree3c7770ea846123c291f599044e9f234ac17616bb /unexalpha.c
parent8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff)
parentdeda2c0fd8689349fea2a900199a76ff7ecb319e (diff)
downloadscm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz
scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low * Fix hppa compile. Closes: #144062 scm (5d6-3.1) unstable; urgency=low * NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171 scm (5d6-3) unstable; urgency=low * Add build depend on xlibs-dev (Closes: #148020) scm (5d6-2) unstable; urgency=low * Remove libregexx-dev from build-depends. * Change build to use ./scmlit rather than scmlit (should fix some build problems) (looks like alpha is mostly building) * New release (Closes: #140175) * Built with turtlegraphics last time (Closes: #58515) scm (5d6-1) unstable; urgency=low * New upstream. * Add xlib and turtlegr to requested list of features. (closes some bug) * Make clean actually clean most everything up. * Remove hacks renaming build to something else and just set build as a .PHONY target in debian/rules. * Add the turtlegr code. scm (5d5-1) unstable; urgency=low * New upstream * Has fixes for 64 bit archs. May fix alpha compile problem. Does fix (Closes: #140175) * Take out -O2 arg. scm (5d4-3) unstable; urgency=low * Don't link with regexx, but just use libc6's regular expression functions. * Define (terms) to output /usr/share/common-licenses/GPL (Closes: #119321) scm (5d4-2) unstable; urgency=low * Add texinfo to build depends (Closes: #107011) scm (5d4-1) unstable; urgency=low * New upstream release. * Move install-info --remove to prerm. scm (5d3-5) unstable; urgency=low * Move scm info files to section "The Algorithmic Language Scheme" to match up with guile. scm (5d3-4) unstable; urgency=low * Fix build depends (Closes: #76691) scm (5d3-3) unstable; urgency=low * Fix path in scm dhelp file. scm (5d3-2) unstable; urgency=low * Actually put the header files in the package. Oops. scm (5d3-1) unstable; urgency=low * New upstream. (Closes: #74761) * Make (terms) use new license location. * Make use libregexx rather than librx. * Fix build depends for above. * Using new regex lib seems to fix crash (Closes: #66787) * Consider adding scm-dev package with headers, but instead just add the headers to the scm package. (Closes: #70787) * Add doc-base support.
Diffstat (limited to 'unexalpha.c')
-rw-r--r--unexalpha.c36
1 files changed, 22 insertions, 14 deletions
diff --git a/unexalpha.c b/unexalpha.c
index 2adfd1f..69db5fd 100644
--- a/unexalpha.c
+++ b/unexalpha.c
@@ -20,7 +20,15 @@ the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
-#include <config.h>
+#ifndef emacs
+# ifndef __ELF__
+ /* Describe layout of the address space in an executing process. */
+# define TEXT_START 0x120000000
+# define DATA_START 0x140000000
+# endif
+#else
+# include <config.h>
+#endif
#include <sys/types.h>
#include <sys/file.h>
#include <sys/stat.h>
@@ -93,7 +101,7 @@ struct headers {
/* Define name of label for entry point for the dumped executable. */
#ifndef DEFAULT_ENTRY_ADDRESS
-#define DEFAULT_ENTRY_ADDRESS __start
+# define DEFAULT_ENTRY_ADDRESS __start
#endif
unexec (new_name, a_name, data_start, bss_start, entry_address)
@@ -194,10 +202,10 @@ unexec (new_name, a_name, data_start, bss_start, entry_address)
#endif
#ifdef _PDATA
CHECK_SCNHDR (pdata_section, _PDATA, STYP_PDATA);
-#endif _PDATA
+#endif /* _PDATA */
#ifdef _GOT
CHECK_SCNHDR (got_section, _GOT, STYP_GOT);
-#endif _GOT
+#endif /* _GOT */
CHECK_SCNHDR (data_section, _DATA, STYP_DATA);
#ifdef _XDATA
CHECK_SCNHDR (xdata_section, _XDATA, STYP_XDATA);
@@ -315,7 +323,7 @@ unexec (new_name, a_name, data_start, bss_start, entry_address)
"writing data section to %s", new_name);
#ifdef _GOT
-#define old_got_section ((struct scnhdr *)buffer)
+# define old_got_section ((struct scnhdr *)buffer)
if (got_section != NULL)
{
@@ -327,7 +335,7 @@ unexec (new_name, a_name, data_start, bss_start, entry_address)
"seeking to end of data section of %s", new_name);
}
-#undef old_got_section
+# undef old_got_section
#endif
/*
@@ -408,10 +416,10 @@ update_dynamic_symbols (old, new_name, new, aout)
x = ds_base[rd_base[i].index];
-#if 0
+# if 0
fprintf (stderr, "Object inspected: %s, addr = %lx, shndx = %x",
old + dynstr_section->s_scnptr + x.st_name, rd_base[i].addr, x.st_shndx);
-#endif
+# endif
if ((ELF32_ST_BIND (x.st_info) == STB_GLOBAL)
@@ -433,13 +441,13 @@ update_dynamic_symbols (old, new_name, new, aout)
unsigned long newref = aout.tsize + reladdr;
int len;
-#if 0
+# if 0
fprintf (stderr, "...relocated\n");
-#endif
+# endif
- if (rd_base[i].type == R_REFLONG)
+ if (rd_base[i].type == R_REFLONG)
len = 4;
- else if (rd_base[i].type == R_REFQUAD)
+ else if (rd_base[i].type == R_REFQUAD)
len = 8;
else
fatal_unexec ("unrecognized relocation type in .dyn.rel section (symbol #%d)", i);
@@ -448,10 +456,10 @@ update_dynamic_symbols (old, new_name, new, aout)
WRITE (new, oldref, len, "writing old dynrel info in %s", new_name);
}
-#if 0
+# if 0
else
fprintf (stderr, "...not relocated\n");
-#endif
+# endif
}