aboutsummaryrefslogtreecommitdiffstats
path: root/subr.c
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2005-10-27 12:00:49 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:29 -0800
commit4e063c0de0bf319c9201cefa6f399364041bb7b9 (patch)
tree61a326cd4ab69f610d2e10313db2a641b6d0b4dd /subr.c
parent5f7b0413c1bb0f96bb613ad74c0978f44116a136 (diff)
parent302e3218b7d487539ec305bf23881a6ee7d5be99 (diff)
downloadscm-4e063c0de0bf319c9201cefa6f399364041bb7b9.tar.gz
scm-4e063c0de0bf319c9201cefa6f399364041bb7b9.zip
Import Debian changes 5e1-1debian/5e1-1
scm (5e1-1) unstable; urgency=low * New upstream release. (Closes: #335970) * debian/rules (SCM_OPTIONS): Remove -F turtlegr; the file supporting this option seems to have gone by the wayside. * debian/rules (binary-arch): Don't try to install grtest.scm; it's gone now. * debian/rules (build-stamp): Use tee to capture output of ./build so that we can capture a copy of the file in the build log. * scm.1: Fix spelling errors in manual page: verobse -> verbose; qoutes -> quotes; aguments -> arguments; neccessary -> necessary; preceeds -> precedes. syncronization -> synchronization. (Closes: #300131) * debian/postinst, debian/prerm: Assume that install-docs is in the standard place, and test for it there with test -x. (Closes: #292996)
Diffstat (limited to 'subr.c')
-rw-r--r--subr.c12
1 files changed, 6 insertions, 6 deletions
diff --git a/subr.c b/subr.c
index f486932..6c6bde9 100644
--- a/subr.c
+++ b/subr.c
@@ -1164,7 +1164,7 @@ SCM scm_logbitp(index, j1)
#else
ASRTER(INUMP(j1), j1, ARG2, s_logbitp);
#endif
- if (index >= LONG_BIT) return j1 < 0 ? BOOL_T : BOOL_F;
+ if (INUM(index) >= LONG_BIT) return j1 < 0 ? BOOL_T : BOOL_F;
return ((1L << INUM(index)) & INUM(j1)) ? BOOL_T : BOOL_F;
}
@@ -1297,19 +1297,19 @@ SCM scm_bitif(mask, n0, n1)
return MAKINUM((INUM(mask) & INUM(n0)) | (~(INUM(mask)) & INUM(n1)));
}
-SCM scm_copybitfield(to, start, rest)
- SCM to, start, rest;
+SCM scm_copybitfield(to, from, rest)
+ SCM to, from, rest;
{
long len;
- SCM end, from;
+ SCM start, end;
#ifndef RECKLESS
if (!(NIMP(rest) && CONSP(rest)))
wna: wta(UNDEFINED, (char *)WNA, s_copybitfield);
#endif
- end = CAR(rest);
+ start = CAR(rest);
rest = CDR(rest);
ASRTGO(NIMP(rest) && CONSP(rest), wna);
- from = CAR(rest);
+ end = CAR(rest);
ASRTGO(NULLP(CDR(rest)), wna);
ASRTER(INUMP(start) && INUM(start)>=0, start, ARG2, s_copybitfield);
len = INUM(end) - INUM(start);