aboutsummaryrefslogtreecommitdiffstats
path: root/hobbit.scm
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2008-02-04 20:53:13 -0500
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:41 -0800
commite9ed1ad5236ca6314136c4220ac672167b643fc5 (patch)
tree5b3d3a3b8c604225515a3ac6b09b6d036b14d165 /hobbit.scm
parent4bf8faaea412b017e299fd17a1b736119c86f18c (diff)
parent90889a692076f2c62486607d0354e0fca52364bc (diff)
downloadscm-e9ed1ad5236ca6314136c4220ac672167b643fc5.tar.gz
scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.zip
Import Debian changes 5e5-1debian/5e5-1
scm (5e5-1) unstable; urgency=low * New upstream release. * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5. * Makefile: Repeat change from 5e3-2. * debian/control (Build-Depends): Require at least version 3b1 of slib. (scm Depends): Likewise. (libscm-dev Depends): Likewise. * Makefile (scm.info): Add explicit dependency on features.txi and platform.txi. For some reason the one through $(texifiles) is failing mysteriously. Perhaps this is a make bug.
Diffstat (limited to 'hobbit.scm')
-rw-r--r--hobbit.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/hobbit.scm b/hobbit.scm
index eff85ba..1c0fa61 100644
--- a/hobbit.scm
+++ b/hobbit.scm
@@ -1,3 +1,20 @@
+;;;; "hobbit.scm": an optimizing scheme -> C compiler for SCM
+;; Copyright (C) 1992-2006 Free Software Foundation
+;;
+;; This program is free software: you can redistribute it and/or modify
+;; it under the terms of the GNU Lesser General Public License as
+;; published by the Free Software Foundation, either version 3 of the
+;; License, or (at your option) any later version.
+;;
+;; This program is distributed in the hope that it will be useful, but
+;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;; Lesser General Public License for more details.
+;;
+;; You should have received a copy of the GNU Lesser General Public
+;; License along with this program. If not, see
+;; <http://www.gnu.org/licenses/>.
+
;====================================================================
;
; HOBBIT: an optimizing scheme -> C compiler for SCM
@@ -5,9 +22,6 @@
; scm5e1
; 2002-04-11
;
-; Copyright (C) 1992-1997: Tanel Tammet
-; Copyright (C) 1998-2006: Free Software Foundation
-;
; tammet@staff.ttu.ee, tammet@cs.chalmers.se
;
; Tanel Tammet
@@ -28,21 +42,6 @@
;
; NB! the terms for usage, copying
; and redistribution of hobbit are given in the file COPYING
-;
-;
-; This program is free software; you can redistribute it and/or modify
-; it under the terms of the GNU General Public License as published by
-; the Free Software Foundation; either version 1, or (at your option)
-; any later version.
-;
-; This program is distributed in the hope that it will be useful,
-; but WITHOUT ANY WARRANTY; without even the implied warranty of
-; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-; GNU General Public License for more details.
-;
-; You should have received a copy of the GNU General Public License
-; along with this program; if not, write to the Free Software
-; Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111, USA.
;====================================================================
;
; Last part of changelog: