aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJames LewisMoss <dres@debian.org>2000-03-12 09:04:17 -0500
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:26 -0800
commit8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (patch)
tree17427e4f777ca85990a449fe939fbae29770b346 /debian/rules
parenta47af30d2f0e96afcd1f14b1984575c359faa3d6 (diff)
parent3278b75942bdbe706f7a0fba87729bb1e935b68b (diff)
downloadscm-8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693.tar.gz
scm-8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693.zip
Import Debian changes 5d2-3debian/5d2-3
scm (5d2-3) unstable frozen; urgency=low * Fix libncurses4-dev -> libncurses5-dev build depend (Closes: #58435) * Fix libreadline2-dev -> libreadline4-dev build depend. * Fix license location in copyright file (lintian warning) * Add tetex-bin as a build depend (needs makeinfo) (Closes: #53197) * Add -isp option to dpkg-gencontrol (lintian error) * Move scm to section interpreters. scm (5d2-2) unstable; urgency=low * Apply patch from upstream for bug in eval.c. (Picked up from comp.lang.scheme) * Add Build-Depends on slib, librx1g-dev, libncurses4-dev, libreadlineg2-dev. * Up standards version. * Correct description: this is an R5RS implementation now * Make sure no optimizations are done on m68k. (Closes: #52434) scm (5d2-1) unstable; urgency=low * New upstream. scm (5d1-2) unstable; urgency=low * Remove TAGS on clean (cut the diff back down to reasonable size). scm (5d1-1) unstable; urgency=low * New upstream. * move stuff to /usr/share. scm (5d0-3) unstable; urgency=low * Change scmlit call to ./scmlit call (missed one) (Fixes bugs #37455 and #35545) * Change man file permissions to 644 (fixes lintian warning) scm (5d0-2) unstable; urgency=low * Removed call to add_final in init_crs. lendwin doesn't do anything and scm was crashing when quit everytime in final_scm. * Changed copyright to reflect new source. scm (5d0-1) unstable; urgency=low * New upstream. * Changed (terms) to access "/usr/doc/copyright/GPL". * Changed regex to use -lrx scm (5c3-6) unstable; urgency=low * New maintainer.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules73
1 files changed, 45 insertions, 28 deletions
diff --git a/debian/rules b/debian/rules
index 07e44fa..bc0618f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,9 +12,17 @@ INSTALL =/usr/bin/install
INSTALL_DIR =$(INSTALL) -d -m 755 -o root -g root
INSTALL_PROGRAM =$(INSTALL) -m 755 -o root -g root
INSTALL_DATA =$(INSTALL) -m 644 -o root -g root
-INSTALL_MAN =$(INSTALL) -m 444 -o root -g root
+INSTALL_MAN =$(INSTALL) -m 644 -o root -g root
-SCM_OPTIONS = -p linux --compiler-options=-O2 --compiler-options=-g \
+ifeq ($(DEB_BUILD_ARCH), m68k)
+COMPILER_OPTIONS=
+else
+COMPILER_OPTIONS=-O2
+endif
+
+SCM_OPTIONS = -p linux \
+ --compiler-options=-g \
+ --compiler-options=$(COMPILER_OPTIONS) \
-F cautious \
-F bignums \
-F arrays \
@@ -25,17 +33,18 @@ SCM_OPTIONS = -p linux --compiler-options=-O2 --compiler-options=-g \
-F generalized-c-arguments \
-F tick-interrupts \
-F i/o-extensions \
- -F curses \
-F edit-line \
-F regex \
-F socket \
-F posix \
-F unix \
+ -F curses \
-F dynamic-linking \
-F dump \
- -F heap-can-shrink \
-F macro
+# -F heap-can-shrink \
+
NON_LIB_FILES = 'bench.scm|build.scm|example.scm|r4rstest.scm|pi.scm'
#test: stamp-configure
@@ -46,21 +55,27 @@ build:
chmod +x bld.scm
$(checkdir)
cp debian/require.scm.debian require.scm
+ifeq ($(DEB_BUILD_ARCH), m68k)
+ ${MAKE} scmlit CFLAGS=-g
+else
${MAKE} scmlit
+endif
test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)
# SCHEME_LIBRARY_PATH=/usr/share/slib/ ./build.scm ${SCM_OPTIONS} > debian/bld
./bld.scm ${SCM_OPTIONS} > debian/bld
chmod ug+x debian/bld
debian/bld
- -rm -f debian/bld
- makeinfo scm.texi -o scm.info
+ #-rm -f debian/bld
+ #makeinfo scm.texi -o scm.info
+ make scm.info
texi2html -monolithic scm.texi
touch build
clean:
$(checkdir)
-rm scm.info* scm.html tmp1 tmp2 scmflags.h scmlit
+ -rm -f scm5d0.info
-rm require.scm scm
make distclean
-rm -f build debian/bld
@@ -77,6 +92,7 @@ binary-arch: checkroot build
$(INSTALL_DIR) debian/tmp
$(INSTALL_DIR) debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/postinst debian/tmp/DEBIAN
+ $(INSTALL_PROGRAM) debian/prerm debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/postrm debian/tmp/DEBIAN
# binaries
@@ -87,38 +103,39 @@ binary-arch: checkroot build
$(INSTALL_DIR) debian/tmp/usr/lib/scm
$(INSTALL_DATA) `ls *.scm | egrep -v ${NON_LIB_FILES}` debian/tmp/usr/lib/scm
$(INSTALL_DATA) slibcat debian/tmp/usr/lib/scm
+ chmod +x debian/tmp/usr/lib/scm/bld.scm
# man pages
- $(INSTALL_DIR) debian/tmp/usr/man/man1
- $(INSTALL_MAN) scm.1 debian/tmp/usr/man/man1
- gzip -9vr debian/tmp/usr/man
+ $(INSTALL_DIR) debian/tmp/usr/share/man/man1
+ $(INSTALL_MAN) scm.1 debian/tmp/usr/share/man/man1
+ gzip -9vr debian/tmp/usr/share/man
# documentation
- $(INSTALL_DIR) debian/tmp/usr/doc/scm
- $(INSTALL_DATA) debian/changelog debian/tmp/usr/doc/scm/changelog.Debian
- $(INSTALL_DATA) ChangeLog debian/tmp/usr/doc/scm
- $(INSTALL_DATA) QUICKREF debian/tmp/usr/doc/scm
- $(INSTALL_DATA) README debian/tmp/usr/doc/scm
- gzip -9v debian/tmp/usr/doc/scm/*
- $(INSTALL_DATA) scm.html debian/tmp/usr/doc/scm
- $(INSTALL_DATA) debian/copyright debian/tmp/usr/doc/scm
+ $(INSTALL_DIR) debian/tmp/usr/share/doc/scm
+ $(INSTALL_DATA) debian/changelog debian/tmp/usr/share/doc/scm/changelog.Debian
+ $(INSTALL_DATA) ChangeLog debian/tmp/usr/share/doc/scm/changelog
+ $(INSTALL_DATA) QUICKREF debian/tmp/usr/share/doc/scm
+ $(INSTALL_DATA) README debian/tmp/usr/share/doc/scm
+ gzip -9v debian/tmp/usr/share/doc/scm/*
+ $(INSTALL_DATA) scm.html debian/tmp/usr/share/doc/scm
+ $(INSTALL_DATA) debian/copyright debian/tmp/usr/share/doc/scm
# examples
- $(INSTALL_DIR) debian/tmp/usr/doc/scm/examples
- $(INSTALL_DATA) r4rstest.scm debian/tmp/usr/doc/scm/examples
- $(INSTALL_DATA) example.scm debian/tmp/usr/doc/scm/examples
- $(INSTALL_DATA) pi.scm debian/tmp/usr/doc/scm/examples
- $(INSTALL_DATA) pi.c debian/tmp/usr/doc/scm/examples
- $(INSTALL_DATA) bench.scm debian/tmp/usr/doc/scm/examples
- $(INSTALL_DATA) split.scm debian/tmp/usr/doc/scm/examples
+ $(INSTALL_DIR) debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) r4rstest.scm debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) example.scm debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) pi.scm debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) pi.c debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) bench.scm debian/tmp/usr/share/doc/scm/examples
+ $(INSTALL_DATA) split.scm debian/tmp/usr/share/doc/scm/examples
# info pages
- $(INSTALL_DIR) debian/tmp/usr/info
- $(INSTALL_DATA) scm.info* debian/tmp/usr/info
- gzip -9 debian/tmp/usr/info/*
+ $(INSTALL_DIR) debian/tmp/usr/share/info
+ $(INSTALL_DATA) scm.info* debian/tmp/usr/share/info
+ gzip -9 debian/tmp/usr/share/info/*
dpkg-shlibdeps scm
- dpkg-gencontrol
+ dpkg-gencontrol -isp
dpkg --build debian/tmp ..
define checkdir