aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/kfreebsd_support.patch
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <iwamatsu@debian.org>2010-03-01 14:58:29 +0900
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:42 -0800
commit407da05523508127184956b50fbaad1c4d81a9c4 (patch)
tree1d67410bfad71e0b3ed289bba51b832f06d1e830 /debian/patches/kfreebsd_support.patch
parent7bfc213c637ef0dc28f6a99b0528978159e0c54f (diff)
downloadscm-407da05523508127184956b50fbaad1c4d81a9c4.tar.gz
scm-407da05523508127184956b50fbaad1c4d81a9c4.zip
Import Debian changes 5e5-3.1debian/5e5-3.1
scm (5e5-3.1) unstable; urgency=low * Non-maintainer upload. ACKed by maintainer. * Update debian/control. - Add support sh4, kfreebsd-amd64 and kfreebsd-i386. (Closes: #558213, #559017) - Replacing libreadline5-dev build dependency with libreadline-dev. (Closes: #553847)
Diffstat (limited to 'debian/patches/kfreebsd_support.patch')
-rw-r--r--debian/patches/kfreebsd_support.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/kfreebsd_support.patch b/debian/patches/kfreebsd_support.patch
new file mode 100644
index 0000000..07166a0
--- /dev/null
+++ b/debian/patches/kfreebsd_support.patch
@@ -0,0 +1,46 @@
+--- scm-5e5.orig/time.c
++++ scm-5e5/time.c
+@@ -73,7 +73,7 @@
+ /* Define this if your system lacks times(). */
+ /* #define LACK_TIMES */
+
+-#ifdef linux
++#if defined(linux) || defined(__GLIBC__)
+ # include <sys/types.h>
+ # include <sys/time.h>
+ # include <sys/timeb.h>
+only in patch2:
+unchanged:
+--- scm-5e5.orig/scmfig.h
++++ scm-5e5/scmfig.h
+@@ -310,7 +310,7 @@
+ # define STDC_HEADERS
+ #endif
+
+-#ifdef linux
++#if defined(linux) || defined(__GLIBC__)
+ # define HAVE_SELECT
+ # define HAVE_SYS_TIME_H
+ # define STDC_HEADERS
+@@ -755,7 +755,7 @@
+ # include <unistd.h>
+ #endif
+
+-#ifdef linux
++#if defined(linux) || defined(__GLIBC__)
+ # include <unistd.h>
+ #endif
+
+only in patch2:
+unchanged:
+--- scm-5e5.orig/findexec.c
++++ scm-5e5/findexec.c
+@@ -51,7 +51,7 @@
+ # include <sys/file.h>
+ # include <sys/param.h>
+ # endif
+-# ifdef linux
++# if defined(linux) || defined(__GLIBC__)
+ # include <string.h>
+ # include <stdlib.h>
+ # include <sys/stat.h>