aboutsummaryrefslogtreecommitdiffstats
path: root/Tscript.scm
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2008-02-04 20:53:13 -0500
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:41 -0800
commite9ed1ad5236ca6314136c4220ac672167b643fc5 (patch)
tree5b3d3a3b8c604225515a3ac6b09b6d036b14d165 /Tscript.scm
parent4bf8faaea412b017e299fd17a1b736119c86f18c (diff)
parent90889a692076f2c62486607d0354e0fca52364bc (diff)
downloadscm-e9ed1ad5236ca6314136c4220ac672167b643fc5.tar.gz
scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.zip
Import Debian changes 5e5-1debian/5e5-1
scm (5e5-1) unstable; urgency=low * New upstream release. * continue.h: Repeat change from 5e1-2. * xgen.scm: Repeat change from 5e2-4. * scm.1: Repeat change from 5e2-4. * build.scm: Repeat change from 5e3-5. * Makefile: Repeat change from 5e3-2. * debian/control (Build-Depends): Require at least version 3b1 of slib. (scm Depends): Likewise. (libscm-dev Depends): Likewise. * Makefile (scm.info): Add explicit dependency on features.txi and platform.txi. For some reason the one through $(texifiles) is failing mysteriously. Perhaps this is a make bug.
Diffstat (limited to 'Tscript.scm')
-rw-r--r--Tscript.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/Tscript.scm b/Tscript.scm
index 22b80ea..a238c61 100644
--- a/Tscript.scm
+++ b/Tscript.scm
@@ -1,3 +1,22 @@
+;;;; "Tscript.scm" transcript-on and transcript-off.
+;; Copyright (C) 1999 Free Software Foundation, Inc.
+;;
+;; This program is free software: you can redistribute it and/or modify
+;; it under the terms of the GNU Lesser General Public License as
+;; published by the Free Software Foundation, either version 3 of the
+;; License, or (at your option) any later version.
+;;
+;; This program is distributed in the hope that it will be useful, but
+;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;; Lesser General Public License for more details.
+;;
+;; You should have received a copy of the GNU Lesser General Public
+;; License along with this program. If not, see
+;; <http://www.gnu.org/licenses/>.
+
+;;; Author: Radey Shouman
+
(define transcript-on #f)
(define transcript-off #f)
@@ -24,7 +43,9 @@
(and (input-port? port)
(lambda ()
(let ((c (read-char port)))
- (write-char c trans)
+ (if (eof-object? c)
+ (close-output-port trans)
+ (write-char c trans))
c)))
(lambda ()
(close-port port)))
@@ -57,4 +78,4 @@
(set! transcript-on trans-on)
(set! transcript-off trans-off))
-(provide 'transcript) \ No newline at end of file
+(provide 'transcript)