aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:37 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:37 -0800
commit710a97992705d67c3ded0d4b270c5978ce29b11f (patch)
treeddcb2f7a91cbb86ce582e74227768b7b898c29e1 /Makefile
parent50eb784bfcf15ee3c6b0b53d747db92673395040 (diff)
downloadscm-710a97992705d67c3ded0d4b270c5978ce29b11f.tar.gz
scm-710a97992705d67c3ded0d4b270c5978ce29b11f.zip
Import Upstream version 5e4upstream/5e4
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile256
1 files changed, 142 insertions, 114 deletions
diff --git a/Makefile b/Makefile
index 76d3c99..1f01857 100644
--- a/Makefile
+++ b/Makefile
@@ -55,7 +55,7 @@ SHOBJS = *.so
#BUILD = ./build -hsystem -p svr4-gcc-sun-ld
BUILD = ./build -hsystem
-# Workaround for unexec on Fedora Core 1 Linux i386
+# Workaround for unexec on Fedora Core 1 GNU/Linux i386
#SETARCH = setarch i386
# http://jamesthornton.com/writing/emacs-compile.html
@@ -104,7 +104,13 @@ hfiles = scm.h scmfig.h setjump.h patchlvl.h continue.h
cfiles = scmmain.c scm.c time.c repl.c ioext.c scl.c sys.c eval.c \
subr.c sc2.c unif.c rgx.c crs.c dynl.c record.c posix.c socket.c\
unix.c rope.c ramap.c gsubr.c edline.c continue.c \
- findexec.c script.c debug.c byte.c differ.c
+ findexec.c script.c debug.c byte.c bytenumb.c differ.c
+ufiles = pre-crt0.c ecrt0.c gmalloc.c unexec.c unexelf.c unexhp9k800.c \
+ unexsunos4.c unexalpha.c unexsgi.c
+# cxux-crt0.s ecrt0.c gmalloc.c pre-crt0.c unexaix.c unexalpha.c \
+# unexapollo.c unexconvex.c unexec.c unexelf.c unexelf1.c \
+# unexencap.c unexenix.c unexfx2800.c unexhp9k800.c unexmips.c \
+# unexnext.c unexnt.c unexsgi.c unexsni.c unexsunos4.c
ofiles = scm.o time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \
continue.o findexec.o script.o debug.o
# continue-ia64.o
@@ -161,6 +167,16 @@ scm: scmlit
$(BUILD) -s $(IMPLPATH) -F cautious bignums arrays # i/o-extensions
$(MAKE) check
+# R4RS interpreter (not dumpable)
+scm4.opt:
+ echo "-F cautious bignums arrays inexact" >> scm4.opt
+ echo "-F engineering-notation dynamic-linking" >> scm4.opt
+# if type gcc; then echo "--compiler-options=\"-fno-guess-branch-probability\"" >> scm4.opt; fi
+scm4: $(cfiles) $(hfiles) build.scm build scm4.opt
+ $(BUILD) -f scm4.opt -o scm -s $(IMPLPATH)
+ -rm $(ofiles) scmmain.o
+ -$(MAKE) check
+
# R5RS interpreter (not dumpable)
scm5.opt:
echo "-F cautious bignums arrays inexact" >> scm5.opt
@@ -169,7 +185,7 @@ scm5.opt:
# if type gcc; then echo "--compiler-options=\"-fno-guess-branch-probability\"" >> scm5.opt; fi
scm5: $(cfiles) $(hfiles) build.scm build scm5.opt
$(BUILD) -f scm5.opt -o scm -s $(IMPLPATH)
- rm $(ofiles) scmmain.o
+ -rm $(ofiles) scmmain.o
-$(MAKE) check
-$(MAKE) checkmacro
@@ -180,7 +196,7 @@ udscm4.opt:
# if type gcc; then echo "--compiler-options=\"-fno-guess-branch-probability\"" >> udscm4.opt; fi
udscm4: $(cfiles) $(hfiles) build.scm build udscm4.opt
$(BUILD) -f udscm4.opt -o udscm4 -s $(IMPLPATH)
- rm $(ofiles) scmmain.o
+ -rm $(ofiles) scmmain.o
dscm4: udscm4 $(ifiles) require.scm
if [ -f /proc/sys/kernel/randomize_va_space -a\
"`cat /proc/sys/kernel/randomize_va_space`" != "0" ]; then {\
@@ -200,9 +216,10 @@ udscm5.opt:
$(MAKE) udscm4.opt
cat udscm4.opt >> udscm5.opt
echo "-F macro" >> udscm5.opt
-udscm5: $(cfiles) $(hfiles) build.scm build udscm5.opt
+udscm5: $(cfiles) $(ufiles) $(hfiles) build.scm build udscm5.opt
$(BUILD) -f udscm5.opt -o udscm5 -s $(IMPLPATH)
- rm $(ofiles) scmmain.o
+ -rm $(ofiles) scmmain.o
+ strip udscm5
dscm5: udscm5 $(ifiles) require.scm
if [ -f /proc/sys/kernel/randomize_va_space -a\
"`cat /proc/sys/kernel/randomize_va_space`" != "0" ]; then {\
@@ -221,15 +238,15 @@ dscm5: udscm5 $(ifiles) require.scm
# R5RS interpreter for debugging with GDB.
gdb.opt: udscm5.opt
- cat udscm5.opt >> gdb.opt
+ cat udscm5.opt > gdb.opt
echo "-F debug" >> gdb.opt
echo "--compiler-options=-Wall" >> gdb.opt
echo "--linker-options=-Wall" >> gdb.opt
echo "-D NO_ENV_CACHE" >> gdb.opt
# echo "-DTEST_FARLOC -DTEST_SCM2PTR" >> gdb.opt
-udgdbscm: gdb.opt
+udgdbscm: gdb.opt $(cfiles) $(ufiles) $(hfiles) build.scm build
$(BUILD) -f gdb.opt -o udgdbscm -s $(IMPLPATH)
-gdbscm: udgdbscm
+gdbscm: udgdbscm $(ifiles) require.scm
echo "(quit)" | $(SETARCH) ./udgdbscm -no-init-file -r5 -o gdbscm
# R4RS interpreter for profiling
@@ -259,7 +276,7 @@ libtest: libscm.a libtest.c
dlls.opt:
echo "--compiler-options=-Wall" >> dlls.opt
echo "--linker-options=-Wall" >> dlls.opt
-mydlls: dlls.opt
+mydlls: dlls.opt bytenumb.so
$(BUILD) -t dll -f dlls.opt -c ramap.c
$(BUILD) -t dll -f dlls.opt -c record.c
$(BUILD) -t dll -f dlls.opt -c gsubr.c
@@ -280,6 +297,8 @@ db.so: dlls.opt rwb-isam.scm wbtab.scm
if [ -f ../wb/blink.c ]; then \
$(BUILD) -t dll -f dlls.opt -F wb; fi
+bytenumb.so: bytenumb.c scm.h Makefile
+ $(BUILD) -t dll -f dlls.opt -F byte-number inexact bignums
differ.so: differ.c
$(BUILD) -t dll -f dlls.opt -F differ
myturtle: dlls.opt
@@ -292,13 +311,13 @@ x.so: x.c x.h xevent.h dlls.opt
incdir=/usr/include/
x11.scm: inc2scm
rm -f x11.scm
- $(SCMLIT) -l inc2scm x11.scm x: $(incdir) X11/X.h X11/cursorfont.h X11/Xlib.h \
+ $(SCMLIT) -l inc2scm x11.scm x: $(DESTDIR)$(incdir) X11/X.h X11/cursorfont.h X11/Xlib.h \
X11/Xutil.h
keysymdef.scm: inc2scm
rm -f keysymdef.scm
- $(SCMLIT) -l inc2scm keysymdef.scm x: $(incdir) X11/keysym.h X11/keysymdef.h
+ $(SCMLIT) -l inc2scm keysymdef.scm x: $(DESTDIR)$(incdir) X11/keysym.h X11/keysymdef.h
xevent.h xevent.scm xatoms.scm: xgen.scm Makefile
- $(SCMLIT) -l xgen.scm $(incdir)X11/Xlib.h
+ $(SCMLIT) -l xgen.scm $(DESTDIR)$(incdir)X11/Xlib.h
x.h: x.c xevent.h
if [ -x "$(CPROTO)" ]; then $(CPROTO) x.c > x.h; fi
@@ -306,9 +325,15 @@ x.h: x.c xevent.h
checklit:
$(SCMLIT) -fr4rstest.scm -e'(test-sc4)(test-delay)(gc)' \
-e '(or (null? errs) (quit 1))'
+Checklit:
+ $(SCMLIT) --no-symbol-case-fold -fr4rstest.scm -e'(test-sc4)(test-delay)(gc)' \
+ -e '(or (null? errs) (quit 1))'
check: r4rstest.scm
$(SCMEXE) -fr4rstest.scm -e'(test-sc4)(test-cont)(test-delay)(gc)' \
-e '(or (null? errs) (quit 1))'
+Check: r4rstest.scm
+ $(SCMEXE) --no-symbol-case-fold -fr4rstest.scm -e'(test-sc4)(test-cont)(test-delay)(gc)' \
+ -e '(or (null? errs) (quit 1))'
checkmacro: syntest1.scm syntest2.scm r4rstest.scm
$(SCMEXE) -rmacro -fsyntest1.scm -fsyntest2.scm \
-fr4rstest.scm -e'(test-sc4)(test-cont)(test-delay)' -fsyntest1 \
@@ -355,12 +380,12 @@ implcat: $(SHOBJS) mkimpcat.scm
htmldir=../public_html/
dvi: scm.dvi Xlibscm.dvi hobbit.dvi
-scm.dvi: version.txi scm.texi platform.txi features.txi Makefile
- texi2dvi -b -c $(srcdir)scm.texi
+scm.dvi: version.txi scm.texi indexes.texi platform.txi features.txi Makefile
+ texi2dvi -b -c scm.texi
Xlibscm.dvi: version.txi Xlibscm.texi Makefile
- texi2dvi -b -c $(srcdir)Xlibscm.texi
+ texi2dvi -b -c Xlibscm.texi
hobbit.dvi: version.txi hobbit.texi Makefile
- texi2dvi -b -c $(srcdir)hobbit.texi
+ texi2dvi -b -c hobbit.texi
xdvi: scm.dvi
xdvi scm.dvi
Xdvi: Xlibscm.dvi
@@ -369,14 +394,14 @@ hobdvi: hobbit.dvi
xdvi hobbit.dvi
pdf: $(htmldir)scm.pdf $(htmldir)Xlibscm.pdf $(htmldir)hobbit.pdf
-$(htmldir)scm.pdf: version.txi scm.texi platform.txi features.txi Makefile
- texi2pdf -b -c $(srcdir)scm.texi
+$(htmldir)scm.pdf: version.txi scm.texi indexes.texi platform.txi features.txi Makefile
+ texi2pdf -b -c scm.texi
mv scm.pdf $(htmldir)
$(htmldir)Xlibscm.pdf: version.txi Xlibscm.texi Makefile
- texi2pdf -b -c $(srcdir)Xlibscm.texi
+ texi2pdf -b -c Xlibscm.texi
mv Xlibscm.pdf $(htmldir)
$(htmldir)hobbit.pdf: version.txi hobbit.texi Makefile
- texi2pdf -b -c $(srcdir)hobbit.texi
+ texi2pdf -b -c hobbit.texi
mv hobbit.pdf $(htmldir)
xpdf: $(htmldir)scm.pdf
xpdf $(htmldir)scm.pdf
@@ -389,7 +414,7 @@ PREVDOCS = prevdocs/
html: $(htmldir)scm_toc.html $(htmldir)Xlibscm_toc.html $(htmldir)hobbit_toc.html
TEXI2HTML = /usr/local/bin/texi2html -split -verbose
-scm_toc.html: version.txi scm.texi platform.txi features.txi
+scm_toc.html: version.txi scm.texi indexes.texi platform.txi features.txi
${TEXI2HTML} scm.texi
Xlibscm_toc.html: version.txi Xlibscm.texi
${TEXI2HTML} Xlibscm.texi
@@ -409,7 +434,7 @@ $(htmldir)hobbit_toc.html: hobbit_toc.html Makefile
cp hobbit_*.html $(htmldir)
$(PREVDOCS)scm_toc.html:
-$(PREVDOCS)scm.info: srcdir.mk Makefile
+$(PREVDOCS)scm.info: Makefile
cd $(PREVDOCS); unzip -a $(dest)scm*.zip
rm $(PREVDOCS)scm/scm.info
cd $(PREVDOCS)scm; make scm.info; make scm_toc.html
@@ -435,92 +460,116 @@ includedir = $(prefix)include/
README: build build.scm scm.info
$(SCMEXE) -l build -e"(make-readme)"
-info: installinfo
-installinfo: $(infodir)scm.info $(infodir)Xlibscm.info $(infodir)hobbit.info
-
platform.txi: build.scm
$(SCMLIT) -r database-browse -l build.scm -e "(browse build 'platform)" \
> platform.txi
features.txi: build build.scm
$(SCMLIT) -l build -e"(make-features-txi)"
-scm.info: version.txi scm.texi platform.txi features.txi
+scm.info: version.txi scm.texi indexes.texi platform.txi features.txi
makeinfo scm.texi --no-split -o scm.info
mv scm.info scm$(VERSION).info
if [ -f $(PREVDOCS)scm.info ]; \
then infobar $(PREVDOCS)scm.info scm$(VERSION).info scm.info; \
else cp scm$(VERSION).info scm.info; fi
-$(infodir)scm.info: scm.info
- cp -p scm.info $(infodir)scm.info
- -install-info $(infodir)scm.info $(infodir)dir
- -rm $(infodir)scm.info.gz
+$(DESTDIR)$(infodir)scm.info: scm.info
+ mkdir -p $(DESTDIR)$(infodir)
+ cp -p scm.info $(DESTDIR)$(infodir)scm.info
+ -install-info $(DESTDIR)$(infodir)scm.info $(DESTDIR)$(infodir)dir
+ -rm $(DESTDIR)$(infodir)scm.info.gz
Xlibscm.info: version.txi Xlibscm.texi
makeinfo Xlibscm.texi --no-split -o Xlibscm.info
-$(infodir)Xlibscm.info: Xlibscm.info
- cp Xlibscm.info $(infodir)Xlibscm.info
- -install-info $(infodir)Xlibscm.info $(infodir)dir
- -rm $(infodir)Xlibscm.info*.gz
+$(DESTDIR)$(infodir)Xlibscm.info: Xlibscm.info
+ mkdir -p $(DESTDIR)$(infodir)
+ cp Xlibscm.info $(DESTDIR)$(infodir)Xlibscm.info
+ -install-info $(DESTDIR)$(infodir)Xlibscm.info $(DESTDIR)$(infodir)dir
+ -rm $(DESTDIR)$(infodir)Xlibscm.info*.gz
hobbit.info: version.txi hobbit.texi
makeinfo hobbit.texi --no-split -o hobbit.info
-$(infodir)hobbit.info: hobbit.info
- cp hobbit.info $(infodir)hobbit.info
- -install-info $(infodir)hobbit.info $(infodir)dir
- -rm $(infodir)hobbit.info*.gz
+$(DESTDIR)$(infodir)hobbit.info: hobbit.info
+ mkdir -p $(DESTDIR)$(infodir)
+ cp hobbit.info $(DESTDIR)$(infodir)hobbit.info
+ -install-info $(DESTDIR)$(infodir)hobbit.info $(DESTDIR)$(infodir)dir
+ -rm $(DESTDIR)$(infodir)hobbit.info*.gz
+
+info: installinfo
+installinfo: $(DESTDIR)$(infodir)scm.info $(DESTDIR)$(infodir)Xlibscm.info $(DESTDIR)$(infodir)hobbit.info
infoz: installinfoz
-installinfoz: $(infodir)scm.info.gz $(infodir)Xlibscm.info.gz $(infodir)hobbit.info.gz
-$(infodir)scm.info.gz: $(infodir)scm.info
- gzip -f $(infodir)scm.info
-$(infodir)Xlibscm.info.gz: $(infodir)Xlibscm.info
- gzip -f $(infodir)Xlibscm.info
-$(infodir)hobbit.info.gz: $(infodir)hobbit.info
- gzip -f $(infodir)hobbit.info
-
-install: scm.1 db.so wbtab.scm rwb-isam.scm
- test -d $(bindir) || mkdir $(bindir)
- test -d $(mandir) || mkdir $(mandir)
- test -d $(man1dir) || mkdir $(man1dir)
- -cp scm scmlit $(bindir)
- -strip $(bindir)scmlit
- -cp scm.1 $(man1dir)
- test -d $(libdir) || mkdir $(libdir)
- test -d $(libscmdir) || mkdir $(libscmdir)
- -cp $(ifiles) $(hobfiles) COPYING r4rstest.scm $(libscmdir)
- test -f $(libscmdir)require.scm || \
- cp requires.scm $(libscmdir)require.scm
+installinfoz: $(DESTDIR)$(infodir)scm.info.gz $(DESTDIR)$(infodir)Xlibscm.info.gz $(DESTDIR)$(infodir)hobbit.info.gz
+$(DESTDIR)$(infodir)scm.info.gz: $(DESTDIR)$(infodir)scm.info
+ gzip -f $(DESTDIR)$(infodir)scm.info
+$(DESTDIR)$(infodir)Xlibscm.info.gz: $(DESTDIR)$(infodir)Xlibscm.info
+ gzip -f $(DESTDIR)$(infodir)Xlibscm.info
+$(DESTDIR)$(infodir)hobbit.info.gz: $(DESTDIR)$(infodir)hobbit.info
+ gzip -f $(DESTDIR)$(infodir)hobbit.info
+
+install: scm.1
+ test -d $(DESTDIR)$(bindir) || mkdir $(DESTDIR)$(bindir)
+ test -d $(DESTDIR)$(mandir) || mkdir $(DESTDIR)$(mandir)
+ test -d $(DESTDIR)$(man1dir) || mkdir $(DESTDIR)$(man1dir)
+ -cp scm scmlit $(DESTDIR)$(bindir)
+ -strip $(DESTDIR)$(bindir)scmlit
+ -cp scm.1 $(DESTDIR)$(man1dir)
+ test -d $(DESTDIR)$(libdir) || mkdir $(DESTDIR)$(libdir)
+ test -d $(DESTDIR)$(libscmdir) || mkdir $(DESTDIR)$(libscmdir)
+ -cp $(ifiles) $(hobfiles) COPYING r4rstest.scm $(DESTDIR)$(libscmdir)
+ test -f $(DESTDIR)$(libscmdir)require.scm || \
+ cp requires.scm $(DESTDIR)$(libscmdir)require.scm
-cp build build.scm mkimpcat.scm Iedline.scm $(SHOBJS) patchlvl.h\
- $(xafiles) $(libscmdir)
- -cp db.so wbtab.scm rwb-isam.scm $(libscmdir)
+ $(xafiles) $(DESTDIR)$(libscmdir)
+ -cp db.so wbtab.scm rwb-isam.scm $(DESTDIR)$(libscmdir)
+ -cp libscm.dylib $(DESTDIR)$(libdir)
installlib:
- test -d $(includedir) || mkdir $(includedir)
- cp scm.h scmfig.h scmflags.h $(includedir)
- test -d $(libdir) || mkdir $(libdir)
- cp libscm.a $(libdir)libscm.a
+ test -d $(DESTDIR)$(includedir) || mkdir $(DESTDIR)$(includedir)
+ cp scm.h scmfig.h scmflags.h $(DESTDIR)$(includedir)
+ test -d $(DESTDIR)$(libdir) || mkdir $(DESTDIR)$(libdir)
+ cp libscm.a $(DESTDIR)$(libdir)libscm.a
uninstall:
- -rm $(bindir)scm $(bindir)scmlit
- -rm $(man1dir)scm.1
- -rm $(includedir)scm.h $(includedir)scmfig.h $(includedir)scmflags.h
- -rm $(libdir)libscm.a
- -(cd $(libscmdir); rm $(ifiles) $(hobfiles) COPYING r4rstest.scm)
- -(cd $(libscmdir); rm build build.scm mkimpcat.scm \
+ -rm $(DESTDIR)$(bindir)scm $(DESTDIR)$(bindir)scmlit
+ -rm $(DESTDIR)$(man1dir)scm.1
+ -rm $(DESTDIR)$(includedir)scm.h $(DESTDIR)$(includedir)scmfig.h $(DESTDIR)$(includedir)scmflags.h
+ -rm $(DESTDIR)$(libdir)libscm.a
+ -(cd $(DESTDIR)$(libscmdir); rm $(ifiles) $(hobfiles) COPYING r4rstest.scm)
+ -(cd $(DESTDIR)$(libscmdir); rm build build.scm mkimpcat.scm \
$(SHOBJS) patchlvl.h $(xafiles))
- -(cd $(libscmdir); rm db.so wbtab.scm rwb-isam.scm require.scm)
+ -(cd $(DESTDIR)$(libscmdir); rm db.so wbtab.scm rwb-isam.scm require.scm)
uninstallinfo:
- -rm $(infodir)scm.info.gz $(infodir)Xlibscm.info.gz\
- $(infodir)hobbit.info.gz
+ -rm $(DESTDIR)$(infodir)scm.info.gz $(DESTDIR)$(infodir)Xlibscm.info.gz\
+ $(DESTDIR)$(infodir)hobbit.info.gz
scm.doc: scm.1
nroff -man $< | ul -tunknown >$@
-docs: $(infodir)scm.info.gz $(htmldir)scm_toc.html scm.doc \
+docs: $(DESTDIR)$(infodir)scm.info.gz $(htmldir)scm_toc.html scm.doc \
scm.dvi Xlibscm.dvi hobbit.dvi \
$(htmldir)scm.pdf $(htmldir)Xlibscm.pdf $(htmldir)hobbit.pdf
xdvi -s 4 scm.dvi
+winscm5.opt:
+ echo "-F arrays array-for-each byte i/o-extensions" >> winscm5.opt
+ echo "-F bignums inexact engineering-notation" >> winscm5.opt
+ echo "-F cautious rev2-procedures macro" >> winscm5.opt
+ echo "-F wb" >> winscm5.opt
+gw32scmwb.sh: winscm5.opt build.scm Makefile version.txi scmlit
+ ./build -p gnu-win32 -f winscm5.opt -w gw32scmwb.sh
+scm.exe: gw32scmwb.sh
+ ./gw32scmwb.sh
+
+hobbit.html: hobbit.texi
+ makeinfo --html --no-split --no-warn hobbit.texi
+scm.html: scm.texi
+ makeinfo --html --no-split --no-warn --force scm.texi
+
+## to build a windows installer
+## make sure makeinfo and NSIS are available on the commandline
+w32install: scm.exe hobbit.html scm.html
+ makensis scm.nsi
+
#### Stuff for maintaining SCM below ####
ver = $(VERSION)
@@ -529,13 +578,6 @@ version.txi: patchlvl.h
echo @set SCMDATE `date +"%B %Y"` >> version.txi
RM_R = rm -rf
-ufiles = pre-crt0.c ecrt0.c gmalloc.c unexec.c unexelf.c unexhp9k800.c \
- unexsunos4.c unexalpha.c unexsgi.c
-
-# cxux-crt0.s ecrt0.c gmalloc.c pre-crt0.c unexaix.c unexalpha.c \
-# unexapollo.c unexconvex.c unexec.c unexelf.c unexelf1.c \
-# unexencap.c unexenix.c unexfx2800.c unexhp9k800.c unexmips.c \
-# unexnext.c unexnt.c unexsgi.c unexsni.c unexsunos4.c
confiles = scmconfig.h.in mkinstalldirs acconfig-1.5.h install-sh \
configure configure.in Makefile.in COPYING README.unix
@@ -543,10 +585,10 @@ confiles = scmconfig.h.in mkinstalldirs acconfig-1.5.h install-sh \
tfiles = r4rstest.scm example.scm pi.scm pi.c split.scm bench.scm \
syntest2.scm syntest1.scm
dfiles = ANNOUNCE README COPYING scm.1 scm.doc QUICKREF \
- scm.info scm.texi Xlibscm.info Xlibscm.texi hobbit.info hobbit.texi \
+ scm.info scm.texi indexes.texi Xlibscm.info Xlibscm.texi hobbit.info hobbit.texi \
version.txi platform.txi features.txi ChangeLog
mfiles = Makefile build.scm build build.bat requires.scm \
- .gdbinit mkimpcat.scm disarm.scm scm.spec
+ .gdbinit mkimpcat.scm disarm.scm scm.spec scm.nsi
sfiles = setjump.mar setjump.s ugsetjump.s continue-ia64.S \
get-contoffset-ia64.c
wbfiles = wbtab.scm rwb-isam.scm
@@ -558,35 +600,21 @@ CHPAT=$(HOME)/bin/chpat
RSYNC=rsync --rsync-path=bin/rsync -bav
UPLOADEE=swissnet_upload
dest = $(HOME)/dist/
-DOSCM = /misc/usb1/scm/
+DOSCM = /c/Voluntocracy/dist/
temp/scm: $(afiles)
-$(RM_R) temp
- mkdir temp
- mkdir temp/scm
+ mkdir -p temp/scm
ln $(afiles) temp/scm
release: dist pdf # rpm
cvs tag -F scm$(VERSION)
- cp $(srcdir)ANNOUNCE $(htmldir)SCM_ANNOUNCE.txt
+ cp ANNOUNCE $(htmldir)SCM_ANNOUNCE.txt
$(RSYNC) $(htmldir)SCM.html $(htmldir)SCM_ANNOUNCE.txt $(UPLOADEE):public_html/
$(RSYNC) $(dest)README $(dest)scm$(VERSION).zip \
$(dest)scm-$(VERSION)-$(RELEASE).src.rpm $(dest)scm-$(VERSION)-$(RELEASE).i386.rpm \
$(htmldir)hobbit.pdf $(htmldir)Xlibscm.pdf $(UPLOADEE):dist/
# upload $(dest)README $(dest)scm$(VERSION).zip ftp.gnu.org:gnu/jacal/
-# $(MAKE) indiana
-indiana:
- upload $(dest)scm$(VERSION).zip ftp@ftp.cs.indiana.edu:/pub/scheme-repository/incoming
- echo -e \
- 'I have uploaded scm$(VERSION).zip to ftp.cs.indiana.edu:/pub/scheme-repository/incoming\n' \
- 'for placement into ftp.cs.indiana.edu:/pub/scheme-repository/imp/' \
- | mail -s 'SCM upload' -b jaffer scheme-repository-request@cs.indiana.edu
-
-postnews:
- echo -e "Newsgroups: comp.lang.scheme\n" | cat - ANNOUNCE | \
- inews -h -O -S \
- -f "announce@voluntocracy.org (Aubrey Jaffer & Radey Shouman)" \
- -t "SCM$(VERSION) Released" -d world
upzip: $(HOME)/pub/scm.zip
$(RSYNC) $(HOME)/pub/scm.zip $(UPLOADEE):pub/
@@ -615,12 +643,13 @@ scm.com: temp/scm
zip: scm.zip
scm.zip: temp/scm
$(makedev) PROD=scm zip
-doszip: $(DOSCM)dist/scm$(VERSION).zip
-$(DOSCM)dist/scm$(VERSION).zip: temp/scm turtle turtlegr.c grtest.scm
- $(makedev) DEST=$(DOSCM)dist/ PROD=scm ver=$(VERSION) zip
- cd ..; zip -9ur $(DOSCM)dist/scm$(VERSION).zip \
- scm/turtle scm/turtlegr.c scm/grtest.scm
- zip -d $(DOSCM)dist/scm$(VERSION).zip scm/scm.info scm/Xlibscm.info scm/hobbit.info
+doszip: $(DOSCM)scm$(VERSION).zip
+$(DOSCM)scm$(VERSION).zip: temp/scm turtle turtlegr.c grtest.scm SCM.lnk scm.html hobbit.html
+ $(makedev) DEST=$(DOSCM) PROD=scm ver=$(VERSION) zip
+ -cd ..; zip -9ur $(DOSCM)scm$(VERSION).zip \
+ scm/turtle scm/turtlegr.c scm/grtest.scm scm/SCM.lnk \
+ scm/scm.html scm/hobbit.html
+ zip -d $(DOSCM)scm$(VERSION).zip scm/scm.info scm/Xlibscm.info scm/hobbit.info
pubzip: $(HOME)/pub/scm.zip
$(HOME)/pub/scm.zip: temp/scm
$(makedev) DEST=$(HOME)/pub/ PROD=scm zip
@@ -637,13 +666,13 @@ CITERS = ANNOUNCE ../jacal/ANNOUNCE \
$(htmldir)SLIB.html $(htmldir)JACAL.html \
$(htmldir)SCM.html $(htmldir)SIMSYNCH.html \
../jacal/jacal.texi ../wb/wb.texi \
- $(DOSCM)dist/install.bat $(DOSCM)dist/makefile \
- $(DOSCM)dist/mkdisk.bat hobbit.texi hobbit.scm
+ $(DOSCM)install.bat $(DOSCM)makefile \
+ $(DOSCM)mkdisk.bat hobbit.texi hobbit.scm
updates: Init$(ver).scm
$(CHPAT) scm$(VERSION) scm$(ver) $(CITERS)
$(CHPAT) scm-$(VERSION) scm-$(ver) $(CITERS)
- $(CHPAT) $(VERSION) $(ver) ../wb/wb.spec $(htmldir)SCM.html scm.spec
+ $(CHPAT) $(VERSION) $(ver) ../wb/wb.spec $(htmldir)SCM.html scm.spec scm.nsi
Init$(ver).scm:
mv -f Init$(VERSION).scm Init$(ver).scm
@@ -665,8 +694,7 @@ new: updates
configtemp/scm: $(confiles)
-$(RM_R) configtemp/scm
- -mkdir configtemp
- mkdir configtemp/scm
+ -mkdir -p configtemp/scm
ln $(confiles) configtemp/scm
confdist: scmconfig.tar.gz
scmconfig.tar.gz: configtemp/scm
@@ -707,7 +735,7 @@ ctags: $(ctagfiles)
etags $(ctagfiles)
TAGFILES = $(hfiles) $(cfiles) $(ifiles) $(sfiles)\
- version.txi scm.texi Xlibscm.texi hobbit.texi build $(xfiles) $(mfiles)\
+ version.txi scm.texi indexes.texi Xlibscm.texi hobbit.texi build $(xfiles) $(mfiles)\
hobbit.scm
# # $(ufiles) ChangeLog
TAGS: $(TAGFILES)
@@ -721,7 +749,7 @@ clean:
distclean: clean
-rm -f $(EXECFILES) *.o *.obj a.out TAGS implcat slibcat gdbscm
realclean: distclean
- -rm -f scm.doc
+ -rm -f scm.doc scm.html hobbit.html scm.exe scmlit.exe scm~ SCM-*.exe
realempty: temp/scm
-rm -f $(afiles)
myclean: clean