aboutsummaryrefslogtreecommitdiffstats
path: root/.gdbinit
diff options
context:
space:
mode:
authorDavid N. Welton <davidw@efn.org>1998-12-11 20:21:49 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:25 -0800
commita47af30d2f0e96afcd1f14b1984575c359faa3d6 (patch)
tree2ed08ce2d757f917de7c3c7c04fd7e309f454c83 /.gdbinit
parentf64b2806c1d66a1341bb8b1491f384169ab1d65f (diff)
parentdb04688faa20f3576257c0fe41752ec435beab9a (diff)
downloadscm-a47af30d2f0e96afcd1f14b1984575c359faa3d6.tar.gz
scm-a47af30d2f0e96afcd1f14b1984575c359faa3d6.zip
Import Debian changes 5c3-5debian/5c3-5
scm (5c3-5) frozen unstable; urgency=low * debian/rules chmod +x's bld.scm. Fixes #30521. scm (5c3-4) frozen unstable; urgency=low * Made bld.scm executable. Fixes #29578. scm (5c3-3) frozen unstable; urgency=low * -nw * Fixes #16762. * Fixes #18163. * Fixes #18164. * Fixes #23743. * Fixes #24098. * Fixes #24099. * Fixes #24547. scm (5c3-2) frozen unstable; urgency=low * Re-uploading for slink freeze. scm (5c3-1) unstable; urgency=low * New upstream version.
Diffstat (limited to '.gdbinit')
-rw-r--r--.gdbinit16
1 files changed, 15 insertions, 1 deletions
diff --git a/.gdbinit b/.gdbinit
index 6d39779..343b7f1 100644
--- a/.gdbinit
+++ b/.gdbinit
@@ -64,7 +64,7 @@ define scm
call newline(sys_protects[2]),(void)0
end
-define load
+define lload
if (errjmp_bad)
echo sorry, errjmp_bad\n
else
@@ -94,3 +94,17 @@ end
document cdr
CDR of $
end
+
+define disp
+ call iprin1($arg0, sys_protects[2], 0)
+ echo \n
+end
+
+define writ
+ call iprin1($arg0, sys_protects[2], 1)
+ echo \n
+end
+
+
+
+