summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 1710070ed..7a0b4caa0 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -251,9 +251,9 @@ $(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
rm -rf $(GCC_DIR)
$(GCC_CAT) $(DL_DIR)/$(GCC_SOURCE) | tar -C $(TOOLCHAIN_DIR) $(TAR_OPTIONS) -
$(call CONFIG_UPDATE,$(@D))
-ifneq ($(call qstrip, $(BR2_xtensa_core_name)),)
- tar xf $(BR2_xtensa_overlay_dir)/xtensa_$(call qstrip,\
- $(BR2_xtensa_core_name)).tar -C $(@D) include
+ifneq ($(call qstrip, $(BR2_XTENSA_CORE_NAME)),)
+ tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(call qstrip,\
+ $(BR2_XTENSA_CORE_NAME)).tar -C $(@D) --strip-components=1 gcc
endif
touch $@