summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/Config.in42
-rw-r--r--system/system.mk2
2 files changed, 23 insertions, 21 deletions
diff --git a/system/Config.in b/system/Config.in
index 5b66ac0fb..19bdd2d74 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -12,27 +12,6 @@ config BR2_TARGET_GENERIC_ISSUE
help
Select system banner (/etc/issue) to be displayed at login.
-config BR2_TARGET_GENERIC_ROOT_PASSWD
- string "Root password"
- default ""
- help
- Set the initial root password (in clear). It will be md5-encrypted.
-
- If set to empty (the default), then no root password will be set,
- and root will need no password to log in.
-
- WARNING! WARNING!
- Although pretty strong, MD5 is now an old hash function, and
- suffers from some weaknesses, which makes it susceptible to attacks.
- It is showing its age, so this root password should not be trusted
- to properly secure any product that can be shipped to the wide,
- hostile world.
-
- WARNING! WARNING!
- The password appears in clear in the .config file, and may appear
- in the build log! Avoid using a valuable password if either the
- .config file or the build log may be distributed!
-
choice
prompt "/dev management"
default BR2_ROOTFS_DEVICE_CREATION_STATIC
@@ -140,6 +119,27 @@ endif
if BR2_ROOTFS_SKELETON_DEFAULT
+config BR2_TARGET_GENERIC_ROOT_PASSWD
+ string "Root password"
+ default ""
+ help
+ Set the initial root password (in clear). It will be md5-encrypted.
+
+ If set to empty (the default), then no root password will be set,
+ and root will need no password to log in.
+
+ WARNING! WARNING!
+ Although pretty strong, MD5 is now an old hash function, and
+ suffers from some weaknesses, which makes it susceptible to attacks.
+ It is showing its age, so this root password should not be trusted
+ to properly secure any product that can be shipped to the wide,
+ hostile world.
+
+ WARNING! WARNING!
+ The password appears in clear in the .config file, and may appear
+ in the build log! Avoid using a valuable password if either the
+ .config file or the build log may be distributed!
+
config BR2_TARGET_GENERIC_GETTY_PORT
string "Port to run a getty (login prompt) on"
default "ttyS0"
diff --git a/system/system.mk b/system/system.mk
index 3c4d06e69..651f7df0f 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -47,7 +47,9 @@ ifneq ($(TARGET_GENERIC_ISSUE),)
TARGETS += target-generic-issue
endif
+ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
TARGETS += target-root-passwd
+endif
ifneq ($(TARGET_GENERIC_GETTY),)
ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)