summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/x11r7/Config.in1
-rw-r--r--package/x11r7/xkeyboard-config/Config.in7
-rw-r--r--package/x11r7/xkeyboard-config/xkeyboard-config.mk7
4 files changed, 11 insertions, 5 deletions
diff --git a/package/Config.in b/package/Config.in
index bdc1de167..f39ecf6a8 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -155,6 +155,7 @@ source "package/x11r7/Config.in"
comment "X libraries and helper libraries"
source "package/liberation/Config.in"
source "package/libsexy/Config.in"
+source "package/x11r7/xkeyboard-config/Config.in"
comment "X Window managers"
source "package/enlightenment/Config.in"
diff --git a/package/x11r7/Config.in b/package/x11r7/Config.in
index 971ef377a..f7487daab 100644
--- a/package/x11r7/Config.in
+++ b/package/x11r7/Config.in
@@ -257,7 +257,6 @@ if BR2_PACKAGE_XORG7
source package/x11r7/xdata_xbitmaps/Config.in
source package/x11r7/xdata_xcursor-themes/Config.in
source package/x11r7/xcursor-transparent-theme/Config.in
- source package/x11r7/xkeyboard-config/Config.in
endmenu
endif
diff --git a/package/x11r7/xkeyboard-config/Config.in b/package/x11r7/xkeyboard-config/Config.in
index 640bb1d53..5d1d6a72e 100644
--- a/package/x11r7/xkeyboard-config/Config.in
+++ b/package/x11r7/xkeyboard-config/Config.in
@@ -1,8 +1,9 @@
config BR2_PACKAGE_XKEYBOARD_CONFIG
bool "xkeyboard-config"
- select BR2_PACKAGE_XAPP_XKBCOMP
- select BR2_PACKAGE_XLIB_LIBX11
- select BR2_PACKAGE_XPROTO_XPROTO
+ # Runtime dependencies
+ select BR2_PACKAGE_XAPP_XKBCOMP if BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XPROTO_XPROTO if BR2_PACKAGE_XORG7
help
keyboard configuration database for X
diff --git a/package/x11r7/xkeyboard-config/xkeyboard-config.mk b/package/x11r7/xkeyboard-config/xkeyboard-config.mk
index 78ed1ee5d..cdddd9569 100644
--- a/package/x11r7/xkeyboard-config/xkeyboard-config.mk
+++ b/package/x11r7/xkeyboard-config/xkeyboard-config.mk
@@ -3,10 +3,15 @@
# xkeyboard-config
#
#############################################################
+
XKEYBOARD_CONFIG_VERSION = 2.6
XKEYBOARD_CONFIG_SOURCE = xkeyboard-config-$(XKEYBOARD_CONFIG_VERSION).tar.bz2
XKEYBOARD_CONFIG_SITE = http://www.x.org/releases/individual/data/xkeyboard-config/
-XKEYBOARD_CONFIG_DEPENDENCIES = host-gettext host-intltool host-xapp_xkbcomp xlib_libX11 xproto_xproto
+XKEYBOARD_CONFIG_LICENSE = MIT
+XKEYBAORD_CONFIG_LICENSE_FILES = COPYING
+
+XKEYBOARD_CONFIG_DEPENDENCIES = host-gettext host-intltool host-xapp_xkbcomp
+XKEYBOARD_CONFIG_CONF_OPT += --disable-runtime-deps
$(eval $(autotools-package))