summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/libupnp/Config.in9
-rw-r--r--package/libupnp/libupnp.mk13
3 files changed, 23 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 9568729ba..d6babe344 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -163,6 +163,7 @@ source "package/libcgicc/Config.in"
source "package/libeXosip2/Config.in"
source "package/libosip2/Config.in"
source "package/libpcap/Config.in"
+source "package/libupnp/Config.in"
if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
source "package/lighttpd/Config.in"
endif
diff --git a/package/libupnp/Config.in b/package/libupnp/Config.in
new file mode 100644
index 000000000..6b1a6cf99
--- /dev/null
+++ b/package/libupnp/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBUPNP
+ bool "libupnp"
+ help
+ The portable SDK for UPnP(tm) Devices (libupnp) provides developers
+ with an API and open source code for building control points,
+ devices, and bridges that are compliant with Version 1.0 of the
+ Universal Plug and Play Device Architecture Specification
+
+ http://pupnp.sourceforge.net/
diff --git a/package/libupnp/libupnp.mk b/package/libupnp/libupnp.mk
new file mode 100644
index 000000000..9cd2e7f82
--- /dev/null
+++ b/package/libupnp/libupnp.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# libupnp
+#
+#############################################################
+LIBUPNP_VERSION:=1.6.6
+LIBUPNP_SOURCE:=libupnp-$(LIBUPNP_VERSION).tar.bz2
+LIBUPNP_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/pupnp
+
+LIBUPNP_INSTALL_STAGING:=YES
+LIBUPNP_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
+
+$(eval $(call AUTOTARGETS,package,libupnp))