summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/pciutils/Config.in3
-rw-r--r--package/pciutils/pciutils.mk7
2 files changed, 6 insertions, 4 deletions
diff --git a/package/pciutils/Config.in b/package/pciutils/Config.in
index 7b318dae7..a082f2399 100644
--- a/package/pciutils/Config.in
+++ b/package/pciutils/Config.in
@@ -4,7 +4,4 @@ config BR2_PACKAGE_PCIUTILS
Various utilities dealing with the PCI bus.
Provides things like setpci and lspci.
- You'll need a copy of pci.ids or pci.ids.gz in your
- target skeleton to enjoy verbose output.
-
http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 52f5f67ff..28f80d462 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -4,7 +4,7 @@
#
#############################################################
-PCIUTILS_VERSION = 3.1.7
+PCIUTILS_VERSION = 3.1.8
PCIUTILS_SITE = ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
ifeq ($(BR2_PACKAGE_ZLIB),y)
PCIUTILS_ZLIB=yes
@@ -15,6 +15,11 @@ endif
PCIUTILS_DNS=no
PCIUTILS_SHARED=yes
+# Build after busybox since it's got a lightweight lspci
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+ PCIUTILS_DEPENDENCIES += busybox
+endif
+
define PCIUTILS_CONFIGURE_CMDS
$(SED) 's/wget --no-timestamping/wget/' $(PCIUTILS_DIR)/update-pciids.sh
$(SED) 's/uname -s/echo Linux/' \