summaryrefslogtreecommitdiffstats
path: root/package/yasm
diff options
context:
space:
mode:
Diffstat (limited to 'package/yasm')
-rw-r--r--package/yasm/Config.in9
-rw-r--r--package/yasm/yasm.mk20
2 files changed, 29 insertions, 0 deletions
diff --git a/package/yasm/Config.in b/package/yasm/Config.in
new file mode 100644
index 000000000..bb1d41722
--- /dev/null
+++ b/package/yasm/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_YASM
+ bool "yasm"
+ depends on BR2_i386 || BR2_x86_64
+ help
+ Yasm is a complete rewrite of the NASM-2.10.01 assembler.
+ It supports the x86 and AMD64 instruction sets, accepts NASM
+ and GAS assembler syntaxes and outputs binary, ELF32 and ELF64
+ object formats.
+
diff --git a/package/yasm/yasm.mk b/package/yasm/yasm.mk
new file mode 100644
index 000000000..ac75d2b6a
--- /dev/null
+++ b/package/yasm/yasm.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# yasm
+#
+#############################################################
+YASM_VERSION = 1.2.0
+YASM_SOURCE = yasm-$(YASM_VERSION).tar.gz
+YASM_SITE = http://www.tortall.net/projects/yasm/releases/
+YASM_CONF_OPT = --disable-static
+
+define YASM_PRE_CONFIGURE_FIXUP
+# This sed prevents it compiling 2 programs (vsyasm and ytasm)
+# that are only of use on Microsoft Windows.
+ sed -i 's#) ytasm.*#)#' $(@D)/Makefile.in
+endef
+
+YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))