summaryrefslogtreecommitdiffstats
path: root/package/wvstreams
diff options
context:
space:
mode:
Diffstat (limited to 'package/wvstreams')
-rw-r--r--package/wvstreams/wvstreams.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/wvstreams/wvstreams.mk b/package/wvstreams/wvstreams.mk
index 65f48d403..b4f7d8929 100644
--- a/package/wvstreams/wvstreams.mk
+++ b/package/wvstreams/wvstreams.mk
@@ -27,6 +27,10 @@ WVSTREAMS_CONF_OPT += \
# needed for openssl detection when statically linking (as ssl needs lz)
WVSTREAMS_CONF_ENV += LIBS=-lz
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+ WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endif
+
ifeq ($(BR2_PACKAGE_DBUS),y)
WVSTREAMS_DEPENDENCIES += dbus
WVSTREAMS_CONF_OPT += --with-dbus