summaryrefslogtreecommitdiffstats
path: root/package/wvstreams
diff options
context:
space:
mode:
authorMarkos Chandras <markos.chandras@imgtec.com>2013-06-20 15:14:10 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-20 17:08:18 +0200
commit31d72937cf17e9e476e956986030e93f8fd2ce56 (patch)
tree0c002308968b625461fcd6d41c0813181c8443ce /package/wvstreams
parentb4c20a0353acf0440ab6c8e9f6a5d765a61a585e (diff)
downloadbuildroot-novena-31d72937cf17e9e476e956986030e93f8fd2ce56.tar.gz
buildroot-novena-31d72937cf17e9e476e956986030e93f8fd2ce56.zip
wvstreams: Pass -fPIC to CFLAGS when building PIC objects
The argp bundled dependency which is linked to the libwvutils.so shared library, wasn't built with -fPIC. MIPS will refuce to link a non-PIC library with a shared one. We fix this problem by appending -fPIC to CFLAGS and build all the shared objects with -fPIC. [Peter: use +=] Signed-off-by: Markos Chandras <markos.chandras@imgtec.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wvstreams')
-rw-r--r--package/wvstreams/wvstreams.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/wvstreams/wvstreams.mk b/package/wvstreams/wvstreams.mk
index 65f48d403..b4f7d8929 100644
--- a/package/wvstreams/wvstreams.mk
+++ b/package/wvstreams/wvstreams.mk
@@ -27,6 +27,10 @@ WVSTREAMS_CONF_OPT += \
# needed for openssl detection when statically linking (as ssl needs lz)
WVSTREAMS_CONF_ENV += LIBS=-lz
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+ WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endif
+
ifeq ($(BR2_PACKAGE_DBUS),y)
WVSTREAMS_DEPENDENCIES += dbus
WVSTREAMS_CONF_OPT += --with-dbus