summaryrefslogtreecommitdiffstats
path: root/package/wipe/wipe-dont-force-lfs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/wipe/wipe-dont-force-lfs.patch')
-rw-r--r--package/wipe/wipe-dont-force-lfs.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/wipe/wipe-dont-force-lfs.patch b/package/wipe/wipe-dont-force-lfs.patch
new file mode 100644
index 000000000..08916e24a
--- /dev/null
+++ b/package/wipe/wipe-dont-force-lfs.patch
@@ -0,0 +1,16 @@
+LARGEFILE support shouldn't be forced into CFLAGS
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura wipe-2.3.1/configure.in wipe-2.3.1-lfs/configure.in
+--- wipe-2.3.1/configure.in 2009-06-15 22:55:11.000000000 -0300
++++ wipe-2.3.1-lfs/configure.in 2012-03-05 11:25:30.463221948 -0300
+@@ -91,7 +91,7 @@
+ test "$with_efence" = "yes" && temp2CFLAGS="$debugCFLAGS" && LIBS="-lefence"
+
+ DEBUG="$debugCFLAGS $fullCFLAGS"
+-fullCFLAGS="$temp2CFLAGS $fullCFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
++fullCFLAGS="$temp2CFLAGS $fullCFLAGS"
+ CFLAGS="$checkCFLAGS -D__USE_BSD -D_BSD_SOURCE -D__USE_POSIX -D_POSIX_SOURCE -D_POSIX_MAPPED_FILES"
+
+ dnl Checks for libraries.