summaryrefslogtreecommitdiffstats
path: root/package/webkit
diff options
context:
space:
mode:
Diffstat (limited to 'package/webkit')
-rw-r--r--package/webkit/webkit.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index 580c5d254..326be146d 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -9,7 +9,13 @@ WEBKIT_SITE = http://www.webkitgtk.org
WEBKIT_INSTALL_STAGING = YES
WEBKIT_DEPENDENCIES = host-flex host-gperf icu libcurl libxml2 libxslt \
libgtk2 sqlite enchant libsoup jpeg libgail
-WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config
+
+# Give explicit path to icu-config, and silence gazillions of warnings
+# with recent gcc versions.
+WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
+ CFLAGS="$(TARGET_CFLAGS) -Wno-cast-align" \
+ CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align"
+
ifeq ($(BR2_PACKAGE_XORG7),y)
WEBKIT_CONF_OPT += --with-target=x11