summaryrefslogtreecommitdiffstats
path: root/package/unionfs
diff options
context:
space:
mode:
Diffstat (limited to 'package/unionfs')
-rw-r--r--package/unionfs/unionfs-fuse-no-cxx-needed.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/unionfs/unionfs-fuse-no-cxx-needed.patch b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
new file mode 100644
index 000000000..56f7e2455
--- /dev/null
+++ b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
@@ -0,0 +1,19 @@
+By default, CMake assumes a project uses the C and C++ languages, so
+it checks for both the C and the C++ compiler to exist.
+
+However, unionfs-fuse is written purely in C, so checking for a C++
+compiler is useless, and even prevents unionfs-fuse from building
+properly on targets for which no C++ compiler is available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-project(unionfs-fuse)
++project(unionfs-fuse C)
+
+ cmake_minimum_required(VERSION 2.0)
+ INCLUDE (CheckIncludeFiles)