summaryrefslogtreecommitdiffstats
path: root/package/unionfs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-10-13 23:21:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-14 11:38:48 +0200
commit7b0e4f21d30cf115baa8b57a7edd7683d58ced6f (patch)
tree7558f850a3a22e34398fec2c30fa3af67e5a5d7d /package/unionfs
parent4006b76570faa25453198af25947a86bdbf3b02a (diff)
downloadbuildroot-novena-7b0e4f21d30cf115baa8b57a7edd7683d58ced6f.tar.gz
buildroot-novena-7b0e4f21d30cf115baa8b57a7edd7683d58ced6f.zip
unionfs: add patch to disable search for the C++ compiler
Fixes http://autobuild.buildroot.org/results/9c4a9897dda1b99cc7a57af605301b53ed32b95d/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/unionfs')
-rw-r--r--package/unionfs/unionfs-fuse-no-cxx-needed.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/unionfs/unionfs-fuse-no-cxx-needed.patch b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
new file mode 100644
index 000000000..56f7e2455
--- /dev/null
+++ b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
@@ -0,0 +1,19 @@
+By default, CMake assumes a project uses the C and C++ languages, so
+it checks for both the C and the C++ compiler to exist.
+
+However, unionfs-fuse is written purely in C, so checking for a C++
+compiler is useless, and even prevents unionfs-fuse from building
+properly on targets for which no C++ compiler is available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-project(unionfs-fuse)
++project(unionfs-fuse C)
+
+ cmake_minimum_required(VERSION 2.0)
+ INCLUDE (CheckIncludeFiles)