summaryrefslogtreecommitdiffstats
path: root/package/tremor/tremor.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/tremor/tremor.mk')
-rw-r--r--package/tremor/tremor.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/tremor/tremor.mk b/package/tremor/tremor.mk
index fceee1bdc..cd1d32363 100644
--- a/package/tremor/tremor.mk
+++ b/package/tremor/tremor.mk
@@ -12,4 +12,11 @@ TREMOR_AUTORECONF = YES
TREMOR_INSTALL_STAGING = YES
TREMOR_DEPENDENCIES = libogg
+# tremor has ARM assembly code that cannot be compiled in Thumb2 mode,
+# so we must force the traditional ARM mode.
+ifeq ($(BR2_arm),y)
+TREMOR_CONF_ENV = \
+ CFLAGS="$(TARGET_CFLAGS) -marm"
+endif
+
$(eval $(autotools-package))