summaryrefslogtreecommitdiffstats
path: root/package/sudo/sudo.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/sudo/sudo.mk')
-rw-r--r--package/sudo/sudo.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/sudo/sudo.mk b/package/sudo/sudo.mk
index 3e548ef41..71dacecb7 100644
--- a/package/sudo/sudo.mk
+++ b/package/sudo/sudo.mk
@@ -4,8 +4,10 @@
#
#############################################################
-SUDO_VERSION = 1.8.5p2
+SUDO_VERSION = 1.8.6
SUDO_SITE = http://www.sudo.ws/sudo/dist
+SUDO_LICENSE = ICS BSD-3c
+SUDO_LICENSE_FILES = doc/LICENSE
SUDO_CONF_OPT = \
--without-lecture \
--without-sendmail \
@@ -14,6 +16,13 @@ SUDO_CONF_OPT = \
--without-interfaces \
--without-pam
+# mksigname/mksiglist needs to run on build host to generate source files
+define SUDO_BUILD_MKSIGNAME_MKSIGLIST_HOST
+ $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D)/compat mksigname mksiglist
+endef
+
+SUDO_POST_CONFIGURE_HOOKS += SUDO_BUILD_MKSIGNAME_MKSIGLIST_HOST
+
define SUDO_PERMISSIONS
/usr/bin/sudo f 4755 0 0 - - - - -
endef