summaryrefslogtreecommitdiffstats
path: root/package/stress
diff options
context:
space:
mode:
Diffstat (limited to 'package/stress')
-rw-r--r--package/stress/stress.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/stress/stress.mk b/package/stress/stress.mk
index 3a047b569..a20b0c6f6 100644
--- a/package/stress/stress.mk
+++ b/package/stress/stress.mk
@@ -10,4 +10,14 @@ STRESS_VERSION = 1.0.4
STRESS_SITE = http://weather.ou.edu/~apw/projects/stress
STRESS_AUTORECONF = YES
+# Stress is linked statically if the --enable-static is specified.
+# However, this option is always specified in the global
+# SHARED_STATIC_LIBS_OPTS to tell packages to build static libraries,
+# if supported.
+#
+# If the BR2_PREFER_STATIC_LIB is not defined, we have to specify
+# --disable-static explicitly to get stress linked dynamically.
+STRESS_CONF_OPT = \
+ $(if $(BR2_PREFER_STATIC_LIB),,--disable-static)
+
$(eval $(autotools-package))