summaryrefslogtreecommitdiffstats
path: root/package/stress
diff options
context:
space:
mode:
authorroylee17 <roylee17@gmail.com>2013-03-04 07:47:20 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-04 20:58:39 +0100
commit1b9a4f1e91ac98d836775c293acb9a947b846de1 (patch)
tree224b0e477f2e4ea2e23f0fa99c865562dc21686c /package/stress
parent63b2ee6b86e2214362bc75cb0363b42d11f15ff5 (diff)
downloadbuildroot-novena-1b9a4f1e91ac98d836775c293acb9a947b846de1.tar.gz
buildroot-novena-1b9a4f1e91ac98d836775c293acb9a947b846de1.zip
stress: honor the BR2_PREFER_STATIC_LIB preference
Stress is linked statically if the --enable-static is specified. However, this option is always specified in the global SHARED_STATIC_LIBS_OPTS to tell packages to build static libraries, if supported. If the BR2_PREFER_STATIC_LIB is not defined, we have to specify --disable-static explicitly to get stress linked dynamically. Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/stress')
-rw-r--r--package/stress/stress.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/stress/stress.mk b/package/stress/stress.mk
index 3a047b569..a20b0c6f6 100644
--- a/package/stress/stress.mk
+++ b/package/stress/stress.mk
@@ -10,4 +10,14 @@ STRESS_VERSION = 1.0.4
STRESS_SITE = http://weather.ou.edu/~apw/projects/stress
STRESS_AUTORECONF = YES
+# Stress is linked statically if the --enable-static is specified.
+# However, this option is always specified in the global
+# SHARED_STATIC_LIBS_OPTS to tell packages to build static libraries,
+# if supported.
+#
+# If the BR2_PREFER_STATIC_LIB is not defined, we have to specify
+# --disable-static explicitly to get stress linked dynamically.
+STRESS_CONF_OPT = \
+ $(if $(BR2_PREFER_STATIC_LIB),,--disable-static)
+
$(eval $(autotools-package))