summaryrefslogtreecommitdiffstats
path: root/package/socat/socat.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/socat/socat.mk')
-rw-r--r--package/socat/socat.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/package/socat/socat.mk b/package/socat/socat.mk
index 5f7feacc2..bd435cf08 100644
--- a/package/socat/socat.mk
+++ b/package/socat/socat.mk
@@ -4,7 +4,7 @@
#
#############################################################
-SOCAT_VERSION = 2.0.0-b4
+SOCAT_VERSION = 2.0.0-b5
SOCAT_SOURCE = socat-$(SOCAT_VERSION).tar.bz2
SOCAT_SITE = http://www.dest-unreach.org/socat/download/
SOCAT_CONF_ENV = sc_cv_termios_ispeed=no \
@@ -12,4 +12,17 @@ SOCAT_CONF_ENV = sc_cv_termios_ispeed=no \
sc_cv_sys_tabdly_shift=11 \
sc_cv_sys_csize_shift=4
+# We need to run autoconf to regenerate the configure script, in order
+# to ensure that the test checking linux/ext2_fs.h works
+# properly. However, the package only uses autoconf and not automake,
+# so we can't use the normal autoreconf logic.
+
+SOCAT_DEPENDENCIES = host-autoconf
+
+define SOCAT_RUN_AUTOCONF
+ (cd $(@D); $(HOST_DIR)/usr/bin/autoconf)
+endef
+
+SOCAT_PRE_CONFIGURE_HOOKS += SOCAT_RUN_AUTOCONF
+
$(eval $(call AUTOTARGETS))