summaryrefslogtreecommitdiffstats
path: root/package/slirp
diff options
context:
space:
mode:
Diffstat (limited to 'package/slirp')
-rw-r--r--package/slirp/Config.in25
-rw-r--r--package/slirp/slirp.mk21
2 files changed, 46 insertions, 0 deletions
diff --git a/package/slirp/Config.in b/package/slirp/Config.in
new file mode 100644
index 000000000..dedded37f
--- /dev/null
+++ b/package/slirp/Config.in
@@ -0,0 +1,25 @@
+config BR2_PACKAGE_SLIRP
+ bool "slirp"
+ help
+ The Spice project aims to provide a complete open source
+ solution for interaction with virtualized desktop devices.
+ The Spice project deals with both the virtualized devices
+ and the front-end. Interaction between front-end and
+ back-end is done using VD-Interfaces.
+
+ This package implements the slirp-part for Spice.
+ Slirp emulates a PPP or SLIP connection over a normal terminal.
+
+ http://www.spice-space.org/
+
+ NOTE:
+ This package has some history of a unique kind:
+ - originally developped as 'slirp' by Danny Gasparovski, and
+ seemingly abandonned (developper /disapeared/)
+ - then re-maintained at sourceforge by "Kelly", up to some
+ time around 2009: http://slirp.sourceforge.net/
+ - during that period, QEMU (Fabrice BELLARD) forked the code
+ and included it in QEMU
+ - and it was imported from this breed by the Spice project
+ around May 2009
+ - which is what we use here
diff --git a/package/slirp/slirp.mk b/package/slirp/slirp.mk
new file mode 100644
index 000000000..b3f4bcdf1
--- /dev/null
+++ b/package/slirp/slirp.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# Spice-slirp
+#
+#############################################################
+
+# There's no tarball releases of slirp, so we use the git repo
+# Also, there's no tag, so we use a random SHA1 (master's HEAD
+# of today)
+SLIRP_VERSION = 8c2da74c1385242f20799fec8c04f8378edc6550
+SLIRP_SITE = git://anongit.freedesktop.org/spice/slirp
+SLIRP_LICENSE = BSD-4c BSD-2c
+# Note: The license file 'COPYRIGHT' is missing from the sources,
+# although some files refer to it.
+SLIRP_INSTALL_STAGING = YES
+
+# As we're using the git tree, there's no ./configure,
+# so we need to autoreconf.
+SLIRP_AUTORECONF = YES
+
+$(eval $(autotools-package))