summaryrefslogtreecommitdiffstats
path: root/package/rpm/rpm.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/rpm/rpm.mk')
-rw-r--r--package/rpm/rpm.mk18
1 files changed, 16 insertions, 2 deletions
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
index 3407f49d3..4d8fe21fa 100644
--- a/package/rpm/rpm.mk
+++ b/package/rpm/rpm.mk
@@ -10,14 +10,28 @@ RPM_AUTORECONF = NO
RPM_DEPENDENCIES = zlib beecrypt neon popt
RPM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/beecrypt -I$(STAGING_DIR)/usr/include/neon -DHAVE_MUTEX_THREAD_ONLY" \
- ac_cv_va_copy=yes
+ ac_cv_va_copy=yes
RPM_CONF_OPT = --disable-build-versionscript --disable-rpath \
--without-selinux \
--without-python --without-perl \
--with-zlib=$(STAGING_DIR) \
--with-libbeecrypt=$(STAGING_DIR) \
- --with-popt=$(STAGING_DIR)
+ --with-popt=$(STAGING_DIR)
+
+ifeq ($(BR2_PACKAGE_PCRE),y)
+RPM_DEPENDENCIES += pcre
+RPM_CONF_OPT += --with-pcre=external
+else
+RPM_CONF_OPT += --with-pcre=no
+endif
+
+ifeq ($(BR2_PACKAGE_FILE),y)
+RPM_DEPENDENCIES += file
+RPM_CONF_OPT += --with-file=external
+else
+RPM_CONF_OPT += --with-file=no
+endif
ifeq ($(BR2_PACKAGE_RPM_XZ_PAYLOADS),y)
RPM_CONF_OPT+=--with-xz