summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 6e960cdcc..71591b724 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -39,6 +39,14 @@ HOST_PYTHON_MAKE_ENV = \
HOST_PYTHON_AUTORECONF = YES
+# Building host python in parallel sometimes triggers a "Bus error"
+# during the execution of "./python setup.py build" in the
+# installation step. It is probably due to the installation of a
+# shared library taking place in parallel to the execution of
+# ./python, causing spurious Bus error. Building host-python with
+# MAKE1 has shown to workaround the problem.
+HOST_PYTHON_MAKE = $(MAKE1)
+
PYTHON_DEPENDENCIES = host-python libffi
HOST_PYTHON_DEPENDENCIES = host-expat host-zlib