summaryrefslogtreecommitdiffstats
path: root/package/python
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-12-15 07:29:38 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-15 19:06:29 +0100
commit4e7b07b4d513dc481b5a0a8c49180f2824fcc967 (patch)
treed56e01fa6b373abeaacdcf9cbe5ed7428ff1ecb3 /package/python
parentc3e9f1cf49d8fb8039e3501417235044813cfa57 (diff)
downloadbuildroot-novena-4e7b07b4d513dc481b5a0a8c49180f2824fcc967.tar.gz
buildroot-novena-4e7b07b4d513dc481b5a0a8c49180f2824fcc967.zip
python: build host-python with MAKE1
Building host-python in parallel sometimes causes "Bus error" during the installation step on our autobuilders, such as: http://autobuild.buildroot.org/results/04bcc907c5e075fe1f39d4f49dcc50ec93708eb4/build-end.log Extensive testing on one autobuilder has shown that building host-python with MAKE1 work arounds this strange problem. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 6e960cdcc..71591b724 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -39,6 +39,14 @@ HOST_PYTHON_MAKE_ENV = \
HOST_PYTHON_AUTORECONF = YES
+# Building host python in parallel sometimes triggers a "Bus error"
+# during the execution of "./python setup.py build" in the
+# installation step. It is probably due to the installation of a
+# shared library taking place in parallel to the execution of
+# ./python, causing spurious Bus error. Building host-python with
+# MAKE1 has shown to workaround the problem.
+HOST_PYTHON_MAKE = $(MAKE1)
+
PYTHON_DEPENDENCIES = host-python libffi
HOST_PYTHON_DEPENDENCIES = host-expat host-zlib