summaryrefslogtreecommitdiffstats
path: root/package/python/python.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/python/python.mk')
-rw-r--r--package/python/python.mk16
1 files changed, 3 insertions, 13 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 363513dc3..975d6f40c 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -151,23 +151,13 @@ endef
PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
#
-# Development files removal
-#
-define PYTHON_REMOVE_DEVFILES
- rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR)-config
- rm -f $(TARGET_DIR)/usr/bin/python2-config
- rm -f $(TARGET_DIR)/usr/bin/python-config
-endef
-
-ifneq ($(BR2_HAVE_DEVFILES),y)
-PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_DEVFILES
-endif
-
-#
# Remove useless files. In the config/ directory, only the Makefile
# and the pyconfig.h files are needed at runtime.
#
define PYTHON_REMOVE_USELESS_FILES
+ rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR)-config
+ rm -f $(TARGET_DIR)/usr/bin/python2-config
+ rm -f $(TARGET_DIR)/usr/bin/python-config
for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/config/ \
-type f -not -name pyconfig.h -a -not -name Makefile` ; do \
rm -f $$i ; \