summaryrefslogtreecommitdiffstats
path: root/package/python/python.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/python/python.mk')
-rw-r--r--package/python/python.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 71591b724..4876dd8b5 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -108,6 +108,10 @@ else
PYTHON_CONF_OPT += --disable-zlib
endif
+ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB),y)
+PYTHON_DEPENDENCIES += openssl
+endif
+
PYTHON_CONF_ENV += \
PYTHON_FOR_BUILD=$(HOST_PYTHON_DIR)/python \
PGEN_FOR_BUILD=$(HOST_PYTHON_DIR)/Parser/pgen \