summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-101-optional-pydoc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python/python-2.7-101-optional-pydoc.patch')
-rw-r--r--package/python/python-2.7-101-optional-pydoc.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/package/python/python-2.7-101-optional-pydoc.patch b/package/python/python-2.7-101-optional-pydoc.patch
new file mode 100644
index 000000000..8d51dc95b
--- /dev/null
+++ b/package/python/python-2.7-101-optional-pydoc.patch
@@ -0,0 +1,81 @@
+Add an option to disable pydoc
+
+It removes 0.5 MB of data from the target plus the pydoc script
+itself.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ Makefile.pre.in | 6 +++++-
+ configure.in | 5 +++++
+ setup.py | 10 +++++++---
+ 3 files changed, 17 insertions(+), 4 deletions(-)
+
+Index: Python-2.7.1/Makefile.pre.in
+===================================================================
+--- Python-2.7.1.orig/Makefile.pre.in
++++ Python-2.7.1/Makefile.pre.in
+@@ -864,7 +864,7 @@
+ multiprocessing multiprocessing/dummy \
+ unittest \
+ lib-old \
+- curses pydoc_data $(MACHDEPS)
++ curses $(MACHDEPS)
+
+ ifeq (@TEST_MODULES@,yes)
+ LIBSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
+@@ -882,6 +882,10 @@
+ unittest/test
+ endif
+
++ifeq (@PYDOC@,yes)
++LIBSUBDIRS += pydoc_data
++endif
++
+ libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
+ @for i in $(SCRIPTDIR) $(LIBDEST); \
+ do \
+Index: Python-2.7.1/configure.in
+===================================================================
+--- Python-2.7.1.orig/configure.in
++++ Python-2.7.1/configure.in
+@@ -2392,6 +2392,11 @@
+ esac])
+ fi
+
++AC_SUBST(PYDOC)
++
++AC_ARG_ENABLE(pydoc,
++ AS_HELP_STRING([--disable-pydoc], [disable pydoc]),
++ [ PYDOC="${enableval}" ], [ PYDOC=yes ])
+
+ AC_SUBST(TEST_MODULES)
+
+Index: Python-2.7.1/setup.py
+===================================================================
+--- Python-2.7.1.orig/setup.py
++++ Python-2.7.1/setup.py
+@@ -2072,6 +2072,12 @@
+ # turn off warnings when deprecated modules are imported
+ import warnings
+ warnings.filterwarnings("ignore",category=DeprecationWarning)
++
++ scripts = ['Tools/scripts/idle', 'Tools/scripts/2to3',
++ 'Lib/smtpd.py']
++ if not '--disable-pydoc' in sysconfig.get_config_var("CONFIG_ARGS"):
++ scripts += [ 'Tools/scripts/pydoc' ]
++
+ setup(# PyPI Metadata (PEP 301)
+ name = "Python",
+ version = sys.version.split()[0],
+@@ -2092,9 +2098,7 @@
+ ext_modules=[Extension('_struct', ['_struct.c'])],
+
+ # Scripts to install
+- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+- 'Tools/scripts/2to3',
+- 'Lib/smtpd.py']
++ scripts = scripts,
+ )
+
+ # --install-platlib