summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-009-python-symlink.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python/python-2.7-009-python-symlink.patch')
-rw-r--r--package/python/python-2.7-009-python-symlink.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/python/python-2.7-009-python-symlink.patch b/package/python/python-2.7-009-python-symlink.patch
new file mode 100644
index 000000000..f284dba55
--- /dev/null
+++ b/package/python/python-2.7-009-python-symlink.patch
@@ -0,0 +1,25 @@
+Use a symlink between python and pythonVERSION
+
+By default, a hard link is used between /usr/bin/python and
+/usr/bin/pythonVERSION. Using hard links for such things is fairly
+uncommon, so let's make a symbolic link instead.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ Makefile.pre.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: Python-2.7.1/Makefile.pre.in
+===================================================================
+--- Python-2.7.1.orig/Makefile.pre.in
++++ Python-2.7.1/Makefile.pre.in
+@@ -791,7 +791,7 @@
+ then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
+ else true; \
+ fi
+- (cd $(DESTDIR)$(BINDIR); $(LN) python$(VERSION)$(EXE) $(PYTHON))
++ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) $(PYTHON))
+ -rm -f $(DESTDIR)$(BINDIR)/python-config
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python-config)
+ -test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)