summaryrefslogtreecommitdiffstats
path: root/package/polkit/polkit.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/polkit/polkit.mk')
-rw-r--r--package/polkit/polkit.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
new file mode 100644
index 000000000..3eb0422be
--- /dev/null
+++ b/package/polkit/polkit.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# polkit
+#
+#############################################################
+
+POLKIT_VERSION = 0.103
+POLKIT_SITE = http://www.freedesktop.org/software/polkit/releases/
+POLKIT_LICENSE = GPLv2
+POLKIT_LICENSE_FILES = COPYING
+
+POLKIT_INSTALL_STAGING = YES
+
+POLKIT_DEPENDENCIES = libglib2 host-intltool expat
+
+# We could also support --with-authfw=pam
+POLKIT_CONF_OPT = \
+ --with-authfw=shadow \
+ --with-os-type=unknown
+
+$(eval $(autotools-package))