summaryrefslogtreecommitdiffstats
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 729f8bbe4..953dbc94c 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -1,3 +1,10 @@
+############################################################################
+#
+# This file contains various utility functions used by the package
+# infrastructure, or by the packages themselves.
+#
+############################################################################
+
# UPPERCASE Macro -- transform its argument to uppercase and replace dots and
# hyphens to underscores
@@ -16,6 +23,12 @@ UPPERCASE = $(strip $(eval __tmp := $1) \
$(__tmp)))) \
$(__tmp))
+#
+# Manipulation of .config files based on the Kconfig
+# infrastructure. Used by the Busybox package, the Linux kernel
+# package, and more.
+#
+
define KCONFIG_ENABLE_OPT
$(SED) "/\\<$(1)\\>/d" $(2)
echo "$(1)=y" >> $(2)