summaryrefslogtreecommitdiffstats
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 16:45:20 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-19 16:08:09 +0200
commitc0e6b52482f244e5da6e8011d1737b0a21cef207 (patch)
treea5a89a9d177050828b3afd421d5f323e5de6dc7b /package/pkg-utils.mk
parent6e6b99a5714834c9330c30dd3af04009f5713204 (diff)
downloadbuildroot-novena-c0e6b52482f244e5da6e8011d1737b0a21cef207.tar.gz
buildroot-novena-c0e6b52482f244e5da6e8011d1737b0a21cef207.zip
pkg-*.mk: add some comments, update some existing comments
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 729f8bbe4..953dbc94c 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -1,3 +1,10 @@
+############################################################################
+#
+# This file contains various utility functions used by the package
+# infrastructure, or by the packages themselves.
+#
+############################################################################
+
# UPPERCASE Macro -- transform its argument to uppercase and replace dots and
# hyphens to underscores
@@ -16,6 +23,12 @@ UPPERCASE = $(strip $(eval __tmp := $1) \
$(__tmp)))) \
$(__tmp))
+#
+# Manipulation of .config files based on the Kconfig
+# infrastructure. Used by the Busybox package, the Linux kernel
+# package, and more.
+#
+
define KCONFIG_ENABLE_OPT
$(SED) "/\\<$(1)\\>/d" $(2)
echo "$(1)=y" >> $(2)