summaryrefslogtreecommitdiffstats
path: root/package/pkg-download.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-download.mk')
-rw-r--r--package/pkg-download.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index e93875988..9e9858100 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -192,8 +192,8 @@ endef
################################################################################
# DOWNLOAD -- Download helper. Will try to download source from:
# 1) BR2_PRIMARY_SITE if enabled
-# 2) Download site
-# 3) BR2_BACKUP_SITE if enabled
+# 2) Download site, unless BR2_PRIMARY_SITE_ONLY is set
+# 3) BR2_BACKUP_SITE if enabled, unless BR2_PRIMARY_SITE_ONLY is set
#
# Argument 1 is the source location
# Argument 2 is the source filename
@@ -213,6 +213,9 @@ define DOWNLOAD_INNER
*) $(call $(DL_MODE)_WGET,$(BR2_PRIMARY_SITE)/$(2),$(2)) && exit ;; \
esac ; \
fi ; \
+ if test "$(BR2_PRIMARY_SITE_ONLY)" = "y" ; then \
+ exit 1 ; \
+ fi ; \
if test -n "$(1)" ; then \
if test -z "$($(PKG)_SITE_METHOD)" ; then \
scheme="$(call geturischeme,$(1))" ; \