summaryrefslogtreecommitdiffstats
path: root/package/pkg-config/pkg-config.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-config/pkg-config.mk')
-rw-r--r--package/pkg-config/pkg-config.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/pkg-config/pkg-config.mk b/package/pkg-config/pkg-config.mk
index 413853d97..bb52db87d 100644
--- a/package/pkg-config/pkg-config.mk
+++ b/package/pkg-config/pkg-config.mk
@@ -13,8 +13,11 @@ PKG_CONFIG_CONF_OPT = --with-installed-glib
HOST_PKG_CONFIG_CONF_OPT = \
--with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
+ --with-sysroot="$(STAGING_DIR)" \
--disable-static
+HOST_PKG_CONFIG_AUTORECONF = YES
+
$(eval $(call AUTOTARGETS,package,pkg-config))
$(eval $(call AUTOTARGETS,package,pkg-config,host))