summaryrefslogtreecommitdiffstats
path: root/package/pixman/pixman.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pixman/pixman.mk')
-rw-r--r--package/pixman/pixman.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
index a2e183225..3e056d419 100644
--- a/package/pixman/pixman.mk
+++ b/package/pixman/pixman.mk
@@ -3,13 +3,18 @@
# pixman
#
################################################################################
-PIXMAN_VERSION = 0.24.2
-PIXMAN_SOURCE = pixman-$(PIXMAN_VERSION).tar.gz
-PIXMAN_SITE = http://cairographics.org/releases/
+PIXMAN_VERSION = 0.25.2
+PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
PIXMAN_INSTALL_STAGING = YES
PIXMAN_DEPENDENCIES = host-pkg-config
# don't build gtk based demos
PIXMAN_CONF_OPT = --disable-gtk
+# disable iwmmxt support for CPU's that don't have
+# this feature
+ifneq ($(BR2_iwmmxt),y)
+PIXMAN_CONF_OPT += --disable-arm-iwmmxt
+endif
+
$(eval $(call AUTOTARGETS))
$(eval $(call AUTOTARGETS,host))