summaryrefslogtreecommitdiffstats
path: root/package/patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/patch')
-rw-r--r--package/patch/Config.in4
-rw-r--r--package/patch/patch.mk6
2 files changed, 7 insertions, 3 deletions
diff --git a/package/patch/Config.in b/package/patch/Config.in
index 5a80ea561..dd6d51c17 100644
--- a/package/patch/Config.in
+++ b/package/patch/Config.in
@@ -1,7 +1,11 @@
config BR2_PACKAGE_PATCH
bool "patch"
+ depends on BR2_USE_WCHAR
help
Take patch files (containing difference listings) and apply them
to original files, producing patched versions.
http://www.gnu.org/software/patch/
+
+comment "patch needs a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/patch/patch.mk b/package/patch/patch.mk
index 80d9db188..5c46c779c 100644
--- a/package/patch/patch.mk
+++ b/package/patch/patch.mk
@@ -3,8 +3,8 @@
# patch
#
#############################################################
-PATCH_VERSION:=2.6
-PATCH_SOURCE:=patch_$(PATCH_VERSION).orig.tar.gz
-PATCH_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/p/patch
+
+PATCH_VERSION = 2.6
+PATCH_SITE = $(BR2_GNU_MIRROR)/patch
$(eval $(call AUTOTARGETS,package,patch))