summaryrefslogtreecommitdiffstats
path: root/package/orc/orc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/orc/orc.mk')
-rw-r--r--package/orc/orc.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/orc/orc.mk b/package/orc/orc.mk
index f89d5cf93..37b6e991c 100644
--- a/package/orc/orc.mk
+++ b/package/orc/orc.mk
@@ -7,4 +7,18 @@ ORC_VERSION = 0.4.14
ORC_SITE = http://code.entropywave.com/download/orc/
ORC_INSTALL_STAGING = YES
+define ORC_REMOVE_BUGREPORT
+ rm -f $(TARGET_DIR)/usr/bin/orc-bugreport
+endef
+
+define ORC_REMOVE_DEVFILES
+ rm -f $(TARGET_DIR)/usr/bin/orcc
+endef
+
+ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_BUGREPORT
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_DEVFILES
+endif
+
$(eval $(call AUTOTARGETS,package,orc))