summaryrefslogtreecommitdiffstats
path: root/package/opus-tools/opus-tools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/opus-tools/opus-tools.mk')
-rw-r--r--package/opus-tools/opus-tools.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/opus-tools/opus-tools.mk b/package/opus-tools/opus-tools.mk
new file mode 100644
index 000000000..233ad9a6e
--- /dev/null
+++ b/package/opus-tools/opus-tools.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# opus-tools
+#
+#############################################################
+
+OPUS_TOOLS_VERSION = 0.1.5
+OPUS_TOOLS_SITE = http://downloads.xiph.org/releases/opus
+OPUS_TOOLS_CONF_OPT = --disable-oggtest --disable-opustest
+OPUS_TOOLS_DEPENDENCIES = opus libogg host-pkg-config
+
+ifeq ($(BR2_PACKAGE_LIBPCAP),y)
+OPUS_TOOLS_DEPENDENCIES += libpcap
+endif
+
+ifeq ($(BR2_X86_CPU_HAS_SSE),y)
+OPUS_TOOLS_CONF_OPT += --enable-sse
+else
+OPUS_TOOLS_CONF_OPT += --disable-sse
+endif
+
+$(eval $(autotools-package))