summaryrefslogtreecommitdiffstats
path: root/package/opengl/libopenmax/libopenmax.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/opengl/libopenmax/libopenmax.mk')
-rw-r--r--package/opengl/libopenmax/libopenmax.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/opengl/libopenmax/libopenmax.mk b/package/opengl/libopenmax/libopenmax.mk
new file mode 100644
index 000000000..430760208
--- /dev/null
+++ b/package/opengl/libopenmax/libopenmax.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# Virtual package for libopenmax
+#
+#############################################################
+
+LIBOPENMAX_SOURCE =
+
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+LIBOPENMAX_DEPENDENCIES += rpi-userland
+endif
+
+ifeq ($(BR2_PACKAGE_BELLAGIO),y)
+LIBOPENMAX_DEPENDENCIES += bellagio
+endif
+
+ifeq ($(LIBOPENMAX_DEPENDENCIES),)
+define LIBOPENMAX_CONFIGURE_CMDS
+ echo "No libopenmax implementation selected. Configuration error."
+ exit 1
+endef
+endif
+
+$(eval $(generic-package))