summaryrefslogtreecommitdiffstats
path: root/package/ocf-linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/ocf-linux')
-rw-r--r--package/ocf-linux/Config.in12
-rw-r--r--package/ocf-linux/ocf-linux.mk21
2 files changed, 33 insertions, 0 deletions
diff --git a/package/ocf-linux/Config.in b/package/ocf-linux/Config.in
new file mode 100644
index 000000000..9dc576607
--- /dev/null
+++ b/package/ocf-linux/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_OCF_LINUX
+ bool "ocf-linux"
+ help
+ OCF-Linux is a Linux port of the OpenBSD/FreeBSD Cryptographic
+ Framework (OCF). This port aims to bring full asynchronous HW/SW
+ crypto acceleration to the Linux kernel and applications
+ running under Linux.
+
+ You need to enable the OCF linux kernel extension or provide
+ a prepatched kernel to make this option useful.
+
+ http://ocf-linux.sourceforge.net/
diff --git a/package/ocf-linux/ocf-linux.mk b/package/ocf-linux/ocf-linux.mk
new file mode 100644
index 000000000..e61522525
--- /dev/null
+++ b/package/ocf-linux/ocf-linux.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# ocf-linux
+#
+#############################################################
+
+OCF_LINUX_VERSION = 20120127
+OCF_LINUX_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/ocf-linux/ocf-linux/$(OCF_LINUX_VERSION)
+OCF_LINUX_INSTALL_STAGING = YES
+
+define OCF_LINUX_INSTALL_STAGING_CMDS
+ $(INSTALL) -D -m 644 $(@D)/ocf/cryptodev.h \
+ $(STAGING_DIR)/usr/include/crypto/cryptodev.h
+endef
+
+define OCF_LINUX_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 644 $(@D)/ocf/cryptodev.h \
+ $(TARGET_DIR)/usr/include/crypto/cryptodev.h
+endef
+
+$(eval $(call GENTARGETS))