summaryrefslogtreecommitdiffstats
path: root/package/ntp/ntp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ntp/ntp.mk')
-rw-r--r--package/ntp/ntp.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/ntp/ntp.mk b/package/ntp/ntp.mk
index f4515fce9..d3c4c70aa 100644
--- a/package/ntp/ntp.mk
+++ b/package/ntp/ntp.mk
@@ -67,6 +67,10 @@ ifeq ($(BR2_PACKAGE_NTP_SNTP),y)
install -m 755 $(NTP_DIR)/sntp/sntp $(TARGET_DIR)/usr/bin/sntp
endif
install -m 755 package/ntp/ntp.sysvinit $(TARGET_DIR)/etc/init.d/S49ntp
+ @if [ ! -f $(TARGET_DIR)/etc/default/ntpd ]; then \
+ install -m 755 -d $(TARGET_DIR)/etc/default ; \
+ install -m 644 package/ntp/ntpd.etc.default $(TARGET_DIR)/etc/default/ntpd ; \
+ fi
ntp: uclibc $(TARGET_DIR)/$(NTP_TARGET_BINARY)